IBM Support

Collecting Data for IBM Spectrum Protect: Server Memory Usage

Troubleshooting


Problem

Collect troubleshooting data documents aid in problem determination and save time resolving Problem Cases (previously called PMRs).

Cause

Gathering this data before calling IBM® support helps us understand the symptom you report and save time analyzing for an explanation.

Resolving The Problem

Collecting data early, even before opening the Case, helps IBM® Support quickly determine whether:
Symptoms match known problems (rediscovery).
There is a non-defect problem that can be identified and resolved.
There is a defect that identifies a workaround to reduce severity.
Locating root cause can speed development of a code fix.

Collecting Data: Table of contents:

Gathering general information
Manually Gathering General Information
Gathering Server Memory Usage Information
Submitting Information to IBM Support
Online Self-Help Resources
Related Information

 
Gathering General Information

Entering general information into an electronically opened Problem Case (previously called PMRs) eliminates waiting on the phone to provide general information to support. 

 
Manually Gathering General Information

Typically memory symptoms develop over time, so it is recommended to use the server monitoring script (see the Related Information section for a URL). The docs collected with the monitoring script have detailed general information and does not make manual collection necessary.
 
Manually Gathering Server Memory Usage Information

Download and activate the server monitoring script, when using version 1.45 or newer specify Y at the following prompt:

Collect SHOW for memory stats? (Y/N)

When running in noprompt mode or to change the default, you can update the following definition from within the script from

my $showmemory   = ""; # include SHOW ALLOC/MEM/MEMTREND command output, valid Y/N
to
my $showmemory   = "Y"; # include SHOW ALLOC/MEM/MEMTREND command output, valid Y/N

When considering the time to collect monitoring data, 72 diagCycles collects information and summarize data on a daily base. You can then use the collCycles parameter and specify 7 collCycles to collect data for a week.

In addition, for the server database part of the investigation, gather the docs as described in What data should I collect for a MEMORY issue with DB2 for Linux, Unix and Windows?

The server monitoring script, when run on *IX systems, automatically collects vmstat information, the DB2 technote documents more OS command output that is required for problem determination.

However, it might be necessary to collect a core file for review by IBM® support, for that condition you get instructions by opening a ticket for the IBM® Spectrum Protect server.  
 
Submitting Information to IBM Support

After a Case is open, you can submit diagnostic troubleshooting data to IBM.

When data is uploaded to the Case, the status is automatically updated to acknowledge that data has been received. If you are still working with older Problem Management Records, you want to update the PMR to indicate that you have sent the data.

 
Online Self-Help Resources
 
Related Information

Related Information

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Product Synonym

TSM

Document Information

Modified date:
04 October 2021

UID

swg22010901