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Search by account in IBM Stewardship Center does different search based on the criteria provided.

Troubleshooting


Problem

IBM Stewardship Center provides the ability to search by account providing various criteria. Type and Number are two attributes among them. When both Type and Number are provided in the UI, details are passed to TCRMPartialSysAdminKeyBObj in TCRMContractSearchBObj for doing searchContract transaction. When only Number is provided in the UI, details are passed to AdminContractId in TCRMContractSearchBObj for doing searchContract transaction. So the search results are different in both the cases.

Cause

MDM SearchContract transaction has two “AdminContractId” fields. One with TCRMContractSearchBObj and one inside TCRMPartialSysAdminKeyBObj that is a child object of TCRMContractSearchBObj. Based on the criteria provided and data available in MDM results of the transaction differ.

Environment

IBM Stewardship Center 11.6.0.4

Resolving The Problem

It is an understanding of what fields on the UI would correspond to the attributes in SearchContract and internally search happens on CONTRACT table or NATIVEKEY table for the results. If only Number field is given in the UI , search happens on CONTRACT table and if both Type and Number fields are given on the UI , search happens on NATIVEKEY table.

[{"Product":{"code":"SSWSR9","label":"IBM InfoSphere Master Data Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"},{"code":"PF010","label":"HP-UX"}],"Version":"11.6.0.4","Edition":"Standard Edition;Advanced Edition","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
27 April 2022

UID

swg22010898