Troubleshooting
Problem
On P8 Content Platform Engine (CPE) 5.2.1.7, the FileNet Configuration Manager (CMUI) returns the following error when trying to connect to a WebSphere Application Server (WAS): Application server cell: com.ibm.ecm.configmgr.engine.ConfigurationManagerException: Connection error: The connection to the application server cannot be established. Ensure the application server is running and that the SOAP connector port and host name are correct.
Symptom
After installing CPE 5.2.1.7, the connection test fails and the Application server cell is not populated in the CMUI Application Server Properties page. Manually typing in the cell does not resolve the connection failure. The following error is returned:
Application server cell: com.ibm.ecm.configmgr.engine.ConfigurationManagerException: Connection error: The connection to the application server cannot be established. Ensure the application server is running and that the SOAP connector port and host name are correct.
Cause
The error was caused by an invalid SSL configuration.
Environment
CPE 5.2.1.7
WebSphere 8.5.5.11
Resolving The Problem
The ssl.client.props file setting for the com.ibm.ssl.protocol did not match the Quality of Protection (QoP) security setting in WebSphere. They need to match exactly.
- From the WebSphere administrative console, click: Security > SSL certificate and key management > SSL configurations > NodeDefaultSSLSettings (your Custom setting ) > Quality of protection (QoP) settings and make note of the protocol setting.
- Browse to the ssl.client.props file. It can usually be found in /AppServer/profiles/<Appserver>/properties.
- The com.ibm.ssl.protocol in ssl.client.props should be set to the exact same value as the QoP protocol. Make changes as needed.
- Example: If the QoP setting is SSL_TLS you should have com.ibm.ssl.protocol=SSL_TLS. If QoP is set to TLS, then you should have com.ibm.ssl.protocol=TLS
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Document Information
Modified date:
17 June 2018
UID
swg22010389