IBM Support

Issues installing InfoSphere Master Data Management on Oracle 12cR2 with ojdbc8.jar on MDMv11.6.0.3 and below

Troubleshooting


Problem

During installation of InfoSphere Master Data Management or InfoSphere MDM Reference Data Managment on Oracle 12cR2 databases, the database connection test step in the IBM Installation Manager database configuration panel fails. This is due to the ODBC JAR file version.

Symptom

During the database connection test on the Database panel in IBM Installation Manager, the following error message is shown:
com.ibm.im.mdm.install.validation.util.OracleService, The database cannot be connected. The database home is not valid.

Cause

The Infosphere MDM or InfoSphere RDM installation application for versions 11.6.0.x do not support ojdbc8.jar while using Oracle 12cR2 as the database.

Environment

Oracle 12c R2

Resolving The Problem

To resolve this issue:

    1. Download ojdbc6.jar from the Oracle web site: http://www.oracle.com/technetwork/apps-tech/jdbc-112010-090769.html
    2. Copy the downloaded ojdbc6.jar file to the JDBC location, <ORACLE_HOME>/jdbc/lib/
    3. Run the installation again from IBM Installation Manager.
    4. On the database configuration panel, click Test Connection to ensure that the connection test is now successful.
    5. Complete the remaining installation steps.

[{"Product":{"code":"SSWSR9","label":"IBM InfoSphere Master Data Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"11.5;11.6;11.6.0.1;11.6.0.2;11.6.0.3","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
27 April 2022

UID

swg22009955