Troubleshooting
Problem
Client uninstall and reinstall can cause the server database backup to fail with ANR4588E
Symptom
You may see the following error in the server activity log:
ANR4588E A database backup configuration might be incorrect.
You may see the following errors in the db2diag.log when the database backup fails:
2017-MM-DD-HH.MM.SS.123456 I5411F916 LEVEL: Error
PID : 6648 TID : 3340 PROC : db2syscs.exe
INSTANCE: SERVER1 NODE : 000 DB : TSMDB1
APPHDL : 0-9455 APPID: *LOCAL.SERVER1.171002224919
AUTHID : DB2USER HOSTNAME: YOURHOST
EDUID : 3340 EDUNAME: db2med.11612.0 (TSMDB1)
FUNCTION: DB2 UDB, database utilities, sqluMapVend2MediaRCWithLog, probe:656
DATA #1 : String, 141 bytes
Vendor error: rc = 30 returned from function sqluvint.
Return_code structure from vendor library C:\PROGRA~1\Tivoli\TSM\db2\bin\db2tsm.dll:
.
Cause
Un install and re-install of the client ( on the server system ) can affect the API environment used to backup up the server database
Diagnosing The Problem
Server ICBACK SESSION trace may show the following errors
RdbDoBackup]: db2BackupSignature is not set and may caused by bad configuration
RdbDoBackup]:Backup database TSMDB1 failed with rc 0 sqlcode -2079 sqlerrmc token is:\PROGRA~1\Tivoli\TSM\db2\bin\db2tsm.dllÿ30 SQLUBMWR.
RdbDoBackup]:The backup DB may have gone to storage pool!!
IcBackupThread]:RdbDoBackup returned with rc = 3336.
IcBackupThread]:Entry: procId=13, full=1, scratch=1, class=YOURCLASS
IcBackupThread]:Calling backup, retry=False, numActualStreams=1.
IcBackupThread]:RdbDoBackup returned with rc = 3336.
Server API, Api_detail trace of failing backup may show the following:
10/02/2017 17:37:39.723 [006648] [11612] : ..\..\common\winnt\psskit.cpp( 586): GSKKMlib::psLoadFunctions(): LoadGSKitLibrary() failed for file 'gsk8km_64.dll': rc = 127.
10/02/2017 17:37:39.723 [006648] [11612] : ..\..\common\ut\GSKitPasswordFile.cpp( 524): GSKitPasswordFile::GSKitPasswordFile:psLoadFunctions failed with error 5802
Resolving The Problem
The following steps resolved the ANR4588E.
1) Uninstall BA client
2) Rename C:\Program Files\Common Files\Tivoli\TSM\api64
3) Rename c:\windows\system32\tsmapi64.dll
4) Rename c:\windows\system32\tsmutil164.dll
5) Rename c:\windows\system32\dsmntapi64.dll
6) Reinstall BA client
7) Restart IBM Spectrum Protect server
8) Run the following command :
d:\tivoli\tsm\server\dsmsutil.exe UPDATEPW /NODE:$$_TSMDBMGR_$$
/PASSWORD:TSMDBMGR /VALIDATE:NO /OPTFILE:
"D:\Tivoli\TSM\SERVER1\tsmdbmgr.opt"
.
NOTE: Your paths may be different when you run the above dsmsutil
.
For more information on the command syntax for dsmsutil.exe, please refer to the link provided.
- start DB backup
Related Information
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Document Information
Modified date:
17 June 2018
UID
swg22009265