IBM Support

Supportability Q&A about IBM Notes and macOS High Sierra (OS X 10.13.x)

News


Abstract

This technote contains questions and answers pertaining to installing and running IBM Notes on Apple's macOS High Sierra (OS X 10.13.x).

Content

** For related technotes about other OS X versions, refer to the Index of Supportability Q&A technotes for Notes and OS X and Windows (technote 1998488) **


Q1. Does IBM Notes support Apple's macOS High Sierra (aka OS X 10.13)?
IBM plans on supporting OS X High Sierra by October 25th, 30 days after High Sierra General Availability. We are currently testing and working on one known install issue covered under the Known Issues section of this document.

In the meantime, customers running IBM Notes 9.0.1 64-bit Interim Fix 11 can open PMRs to report any issues. IBM recommends applying the latest Fix Pack and Interim Fix available to benefit from the latest features and enhancements.

As was announced in Q4 2015 in the following technical document, Notes 9.0.1 Mac 32-bit is not supported with newer Mac operating systems, including macOS High Sierra: Statement of Direction: Recommended client for Mac 64-bit is Notes 9.0.1 64-bit


Q2. Are there any install issues specific to APFS?
Yes, there is an issue with install listed below that can occur on APFS file systems. Macs with SSD drives will be converted to APFS upon upgrading to OS X High Sierra; there is no option to prevent this.

If Notes 9.0.1 64-bit is installed before the upgrade, things will be fine. However, the first attempt to install Notes on a clean machine with APFS after upgrading to macOS High Sierra can result in install failure with the below error message. The second install attempt will succeed. So to work around the issue, you must run the installer a second time. (SPR HPXGAR67YY)
    "File /Applications/Notes.app/Contents/MacOS/rcp/rcplauncher not found. Provisioning process failed to launch or was terminated before status could be determined."

Q3. What versions of Notes are supported on macOS High Sierra?
  • More to come on supported Notes versions after testing and development completes in October.
  • IBM Client Application Access (ICAA) will also be supported in the October timeframe. ICAA for Mac 64-bit is a lightweight solution that helps clients who want to move to a browser-based interface for email (IBM SmartCloud Notes web, IBM Verse, or iNotes), while continuing to work with existing Notes and Domino applications on-premises.

Q4. I'm already at Notes 9.0.1 64-bit, where can I download 9.0.1 Interim Fix 11 or higher?
See this document for a list of fixes and download links for Notes 9.0.1 64-bit Interim Fixes.


Q5. Can I install Notes 32-bit 9.0.1.x or earlier on a Mac running macOS High Sierra?
No. IBM Notes 9.0.1.x 32-bit will not function on macOS High Sierra.


Q6. If I am running Notes 32-bit, what steps can I take to work with macOS High Sierra?
** Note: This information may change based on test results between Sep 25 and Oct 25.**

Install Notes 9.0.1 64-bit + 9.0.1 Interim Fix 11 for Mac. IBM Notes 9.0.1 64-bit for Mac also requires Oracle JRE 1.8 or higher.

Instructions to move from Notes 32-bit to 64-bit
  • Step 1: Uninstall 32-bit Notes 9.0.1. The 32-bit version must be uninstalled first. Attempting to install 64-bit will prompt users to uninstall 32-bit version of Notes first. To uninstall, run the uninstall program using either the 9.0.1 32-bit package or the 9.0.1 64-bit package, which contains an uninstall program.
  • Step 2: Install 64-bit Notes 9.0.1: You can install Notes either before upgrading to macOS High Sierra or after.
  • Step 3: Install 64-bit Notes 9.0.1 Interim Fix 11

Q7. Where can I download IBM Notes 9.0.1 64-bit or the Mac 64-bit API Toolkit that was released in 2015?
** Note : This information may change based on test results between Sep 25 and Oct 25.**

Notes 9.0.1 64-bit is available for download from IBM Passport Advantage Online, Partner downloads, and in IBM Connections Cloud for SmartCloud Notes customers (see below table for more information).

Description
Passport Advantage
Part Number
IBM Notes 9.0.1 MAC 64 bit English
CN6VDEN - Production
CIQ7NEN - Evaluation
IBM Notes v9.0.1 Mac 64 Bit Mac OS X Spanish French & Portuguese Brazilian
CN746ML - Production
CN74EML - Evaluation
IBM Notes v9.0.1 Mac 64 Bit Mac OS X Italian & German
CN747ML - Production
CN74FML - Evaluation
IBM Notes v9.0.1 Mac 64 Bit Mac OS X Japanese & Korean
CN745ML - Production
CN74DML - Evaluation
IBM Notes v9.0.1 Mac 64 Bit Mac OS X Chinese
CN744ML - Production
CN74CML - Evaluation
IBM Notes v9.0.1 Mac 64 Bit Mac OS X Portuguese & Turkish
CN74BML - Production
IBM Notes v9.0.1 Mac 64 Bit Mac OS X Polish & Russian
CN74AML - Production
IBM Notes v9.0.1 Mac 64 Bit Mac OS X Finnish Norwegian & Swedish
CN749ML - Production
IBM Notes v9.0.1 Mac 64 Bit Mac OS X Danish & Dutch
CN748ML - Production
IBM C API Toolkit for Notes/Domino 9.0.1 Mac 64 bit English
CN7GREN

IBM Connections Cloud and IBM SmartCloud Notes customers can download Notes 9.0.1 64-bit. See the following document and use the part numbers above: FAQ: Software downloads for IBM SmartCloud Notes customers.

In addition to Passport advantage or partner downloads, anyone can download the toolkit from the IBM Software Download site as follows:

API Toolkit Download Instructions:
1. Go to the IBM C API Toolkit for Notes/Domino 9.0.1 API Download
2. Navigate through to download the following:

IBM C API Toolkit for Notes/Domino 9.0.1 Mac 64 bit English - C_API_TKT_NOTDOM901_64b_MACEN.zip(18 MB)


Q8. Are there any known issues?
In addition to the APFS-related install issue covered above in Q2, note the following known issues:

IBM Notes 9.0.1.x 32-bit - Not supported, triggers one or more of the following issues:
  • "Failed to launch platform provisioning. Refer to User/<current user./Library/Application Support/IBM Notes Data/Expeditor/Applications/logs/rcplauncher.log for more information."
  • "The Installation Failed. The installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance."
  • “This package is incompatible with this version of OS X and may fail to install”
  • “IBM Notes” cannot be opened. This application requires the legacy Java SE 6 runtime which is unavailable for this version of OS X.

Cross reference information
Segment Product Component Platform Version Edition
Messaging Applications IBM Client Application Access

Document information

More support for: IBM Notes
Install/Setup

Software version: 9.0.1

Operating system(s): OS X

Software edition: 64-bit, Social Edition

Reference #: 2008873

Modified date: 27 September 2017


Translate this page: