Troubleshooting
Problem
The scheduled automatic backup-archive client deployment is successful, but the Tivoli Storage Manager backup-archive client is not upgraded to a new version in a Citrix environment.
Symptom
The updated client packages are sent to the Tivoli Storage Manager client system from the server. A folder to hold the files is generated in the directory:
C:\Program Files\Tivoli\TSM\baclient\IBM_ANR_WIN
Cause
The scheduler installs the updated client by running the DEPLOYCLIENT.BAT command. This command is specified on a postschedulecmd option that is associated with the schedule.
The DEPLOYCLIENT.BAT command cannot run properly. When manually running DEPLOYCLIENT.BAT, the setup.log stops at the following line:
- INSTALLING CALL VCREDIST
This is caused by either permission issue or by the system not having the Windows 8.3 name creation enabled.
Resolving The Problem
Apply the fix for APAR IT20103. If this still does not work, then check the permissions and/or available space for the "C:\Program Files\Tivoli\TSM\baclient\IBM_ANR_WIN" directory. Ensure that this directory location can be written and hold the installation files. If this does not allow the autodeployment to succeed, manually install the backup-archive client.
Related Information
Product Synonym
tsm
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Document Information
Modified date:
17 June 2018
UID
swg22008551