IBM Support

After applying z/OS maintenance I can no longer retrieve OnDemand V2 migrated documents.

Troubleshooting


Problem

I applied the z/OS OAM APAR OA51129 - co-existence (enablement) support for OAM in z/OS V2.3. Binds were done for OAM PLAN CBRIDBS. Since that time I can use OnDemand to retrieve most documents but not the much older documents that were migrated from OnDemand V2. For those V2 documents I see these messages in the ARSSOCKD STC job log: ARS0024E DB21419 Object >2YOEA< in Application Group >PQC< not found in node >OD390V2.COL< Srvr->mvs1.ibm.us 192.22.215.10 non-SSL<- ARS0432E DB21419 V2/IAFC OAM Error: ARSZDOCG: 00000017(00000010) OAM ERROR: FUNCTION= QUERY RETURN CODE= 0000000C REASON-CODE= 9404FCDB, Return Code=23, Reason=0, File=arssmsms.cpp, Line=1762 Srvr->mvs1.ibm.us 192.22.215.10 non-SSL<-

Symptom

OAM REASON-CODE 9404FCDB

Cause

The OAM REASON-CODE 9404FCDB indicates that there is a BIND problem for the ARSZDOCG PLAN.

Note: ARSZDOCG is the default plan name. The parameter ARS_MIGRATE_PLAN in ars.cfg can be used to override the plan name used to retrieve V2 documents from OAM.

Resolving The Problem

Preferred: Install APAR PI86710 for on OnDemand z/OS before installing OAM APAR PI51129

- or -

Perform the following manual steps:

Add package CBRHTBSV.* to the package list for the plan for ARSZDOCG.

Then rebind the plan for ARSZDOCG.

Note: For z/OS 2.3 you will need to additionally add CBRIDBSV.* to the ARSZDOCG plan.

[{"Product":{"code":"SSQHWE","label":"Content Manager OnDemand for z\/OS"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Not Applicable","Platform":[{"code":"PF035","label":"z\/OS"}],"Version":"9.5;9.0;10.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
01 October 2019

UID

swg22008017