IBM Support

After upgrading to a later version of IBM Global Security Kit (GSKit), an IBM Tivoli Storage Manager or IBM Spectrum Protect server might fail to start.

Flash (Alert)


Abstract

After you install IBM software that upgrades the version of IBM Global Security Kit (GSKit) that is installed, an IBM Tivoli Storage Manager or IBM Spectrum Protect server might fail to start. GSKit might be upgraded as part of the installation of IBM software or as part of AIX maintenance.

Content

Summary
An IBM Tivoli Storage Manager or IBM Spectrum Protect server might fail to start when IBM Global Security Kit (GSKit) is upgraded to level 8.0.50.78 or higher.

Symptoms
The server fails to start. Failure symptoms include the following server messages:

    ANR0152I Database manager successfully started.
    ANR0171I dbiconn.c(1826): Error detected on 0:1, database in evaluation mode.
    ANR0162W Supplemental database diagnostic information:  -1:08001:-30082 ([IBM][CLI Driver] SQL30082N  Security processing failed with reason "24" ("USERNAME AND/OR PASSWORD INVALID").  SQLSTATE=08001).
    ANR1820E The server could not connect to the database manager by using TCP/IP port 51500.

Diagnosing the Problem
The following software is known to install GSKit 8.0.50.78 or higher:
  • AIX 7.2 TL1
  • IBM Tivoli Directory Server 6.3
  • IBM Security Directory Server 6.3.1 or later
  • IBM MQ V8.0.0.7 or later
  • IBM Spectrum Protect 8.1.2 client

To determine which level of GSKit is installed, log in as the server instance user and issue the following command to see the Product Version:
    gsk8ver_64

For example:
    %gsk8ver_64

    Details of gskit in /usr/opt/ibm/gsk8_64/lib64


    Operating system is AIX xxx 1 7 000A8DD2D900


    libgsk8sys_64.so
    ============
    @(#)CompanyName:      IBM Corporation
    @(#)LegalTrademarks:  IBM
    @(#)FileDescription:  IBM Global Security Toolkit
    @(#)FileVersion:      8.0.50.78
    @(#)InternalName:     gsksys
    @(#)LegalCopyright:   Licensed Materials - Property of IBM GSKit
                          (C) Copyright IBM Corp.1995, 2017
                          All Rights Reserved. US Government Users
                          Restricted Rights - Use, duplication or disclosure
                          restricted by GSA ADP Schedule Contract with IBM Corp.
    @(#)OriginalFilename: libgsk8sys_64.so
    @(#)ProductName:      gsk8k (GoldCoast Build) 170322
    @(#)ProductVersion:   8.0.50.78
    @(#)ProductInfo:      17/03/08.23:18:22.17/03/22.20:12:34
    @(#)CMVCInfo:         gsk8k_170315/gsk8k_ssl gsk8k_170322/gsk8k_cms gsk8k_170307/gsk8k_doc gsk8k_161014/gsk8k_acme gsk8k_170315/gsk8k_ikm gsk8k_161014/gsk8k_pkg gsk8k_170315/gsk8k_support

Resolving the problem
To resolve the problem, install one of the fix levels. Fixes are available in IBM Spectrum Protect server levels 7.1.7.300 and 8.1.2.000.

Note: IBM Spectrum Protect V8.1.2 includes significant security updates. Before you install the V8.1.2 server, review the product documentation, including the following topics:

For the latest information about security updates, see technote 2004844.

Document information

More support for: IBM Spectrum Protect
Server

Software version: 7.1, 7.1.3, 7.1.4, 7.1.5, 7.1.6, 7.1.7, 8.1, 8.1.1

Operating system(s): Platform Independent

Software edition: All Editions

Reference #: 2007298

Modified date: 24 August 2017


Translate this page: