IBM Support

Toolbar Icons Are Not Displayed in the Scheduler Applications

Troubleshooting


Problem

After upgrading when we open the Gantt View tab in Graphical Scheduling (GS) or the Work or Assignment View tabs in Graphical Assignment (GA) we do not see any icons on the toolbar where zoom in, zoom out, print grid or zoom to fit and all the other toolbar icons should be.

Cause

When using older skins in Maximo, set by the System Property mxe.webclient.skin, some of the older skins may not have all of the images used on the newest skins.

Resolving The Problem

In this case the client was using the classic tivoli skin and saw no icons in GS or GA.
Using tivoli09, most of the icons appeared. Using tivoli13 (the newest one at this time), all of the icons appeared.

To fix this use the most recent skin.

To use an older skin the solution is to copy the IMAGES folder from

...\maximo\applications\maximo\maximouiweb\webmodule\webclient\skins\tivoli13\images

to

...\maximo\applications\maximo\maximouiweb\webmodule\webclient\images

which is the default location for images for all skins.

Then rebuild / redeploy the EAR files and restart the Maximo Application Server.

This had been reported as APAR IV98875 and has been fixed in the 7.6.0.9 Fix Pack.

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Document Information

Modified date:
17 June 2018

UID

swg22006723