IBM Support

Rotating assets into storeroom gives incorrect history ToParent

Troubleshooting


Problem

Moving rotating asset into storerroom gives incorrect history as the link to Parent is not broken

Cause

The move transaction shows that the To Location is the correct storeroom, but the To Parent field shows the original value for Parent, that the user forgot to blank out ToParent.

This means that the Rotating Asset which is now residing in the
storeroom and is obviously not being used, will continue to inherit meter readings from its previous parent, as the logic for the meter reading rolldown is based on the data in the ASSETTRANS object.
This leads to incorrect meter reading values for the moved asset, and interferes with meter based PM scheduling.

So even though the whole scenario is caused by a user mistake in not removing the ToParent, it leads to serious consequences, and the user gets no warning or indication of what is going on.

Instead Maximo should have the same value for parent (ie null) in the ASSET and ASSETTRANS objects, and not allow this mismatch.

Environment

Reproduced in Maximo TPAE 7.5 and 7.6

Tivoli's process automation engine 7.5.0.9-IFIX20150305-1634 Build 20141017-1600 DB Build V7509-40 HFDB Build HF7509-11
Tivoli's process automation engine 7.6.0.8 Build 20170512-0100 DB Build V7608-63

Diagnosing The Problem

Move a rotating asset with children from its operating location into a
storeroom, using the Move/modify asset action:

Asset -> Assets -> Search for Asset with Rotating item that is in
Location HARDWARE
For Example Asset: 1008 with Rotating item WINXP
check Inventory is in HARDWARE and CENTRAL (if not Add items to
Storeroom until you have two storerooms)

Select Action -> Move/Modify Assets
To Parent is A7800
To Location: CENTRAL (ASSETMOVEDFLT.DFLTNEWLOCATION)-> Apply
# Note it must be a storeroom location
# Note To Parent displays A7800 is still there

BMXAA0067I - Asset 1008 in site BEDFORD was moved successfully

Select Action -> View Asset Move History

We now see the: To Parent value is A7800

Resolving The Problem

This functionality has been available since the Maximo 6 version and used extensively by customers.
There is a simple workaround, to create an automation script to clear out the ToParent would resolve their issue or to inform the user should they wish to clear it.

[{"Product":{"code":"SSLKT6","label":"IBM Maximo Asset Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"7.6","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 June 2018

UID

swg22004646