IBM Support

Impact 7.1.0 Fix Pack Install failure

Troubleshooting


Problem

Fix Pack Install failure. Installation of Fixpack fails to complete successfully.

Symptom

Installation of Fix Pack does not complete.

Cause

Need to detect a bad certificate and other issues early in the Fix pack installation process. 

Diagnosing The Problem

Resolving The Problem

Before installing the Impact Fix Packs, it is recommended to run the following health check script to verify the system.

Download from Fix Central:   impact_server_health_check

If any problem is reported by this script, it is essential that these are resolved before the Fix Pack installation is attempted.

NOTE:
The latest version of the health-check is always contained within the Fix Pack itself. It is automatically replaced and run on the system, when the Fix Pack update_console.sh  update_silent.sh or update_gui.sh scripts are used to perform the Fix Pack upgrade. Installing the Fix Pack by way of the Installation Manager, without the use of the update scripts, will bypass the execution of the health-check.  Therefore, it is recommended that the update scripts be used instead.  Alternatively, the downloadable impact_server_health_check can be used before upgrading via Installation Manager.

Instructions for running Health Check Scripts:
  1. Decompress impact_server_health_check.zip  file to the <Impact Install Directory>/install/configuration/cfg_scripts directory
  2. For UNIX, adjust the shell script file permissions using either of the following two commands:
          chmod u+x impact_server_health_check.sh
     or
          chmod 744 impact_server_health_check.sh
  3. Execute either the bat or sh script, from <Impact Install Directory>/install/configuration/cfg_scripts
  4. For UNIX, run using 
    <Impact Install Directory>/install/configuration/cfg_scripts/impact_server_health_check.sh

    For WINDOWS, run using
    <Impact Install Directory>/install/configuration/cfg_scriptsimpact_server_health_check.bat
  5. Scripts are successful if the following is seen:
       BUILD SUCCESSFUL
Only install the Fix Pack if the script is successful.

Please NOTE!!!
  • One of the checks performed by the Health Check is to determine if Impact is functional. For that to happen, the Impact server is started if it is not already running but, is returned to its prior state when the health check completes. The utility does not recycle the Impact server if it is already running.
  • The Impact server Health Check utility can report issues associated with Impact NOI Extensions. Depending on the upgrade path taken, there might be missing columns from Impact's Derby database for NOI.
       There are two known issues, which can be reported and recorded in the file:
       ${impact.home}/logs/install/checkNOI.sql.out
    Issue 1: ij> select IS_FROM_OLD_CONFIG_RUN from SEASONALITY.SEASONALITY_RESULTS_DATA WHERE 2=1;
                ERROR 42X04: Column 'IS_FROM_OLD_CONFIG_RUN' is either not in any table...
    
     
    Issue 2: ij> select DEFAULT_PATTERN_FILTER from RELATEDEVENTS.RE_CONFIGURATION WHERE 2=1;
                ERROR 42X04: Column 'DEFAULT_PATTERN_FILTER' is either not in any table...
       Resolution: The output generated by the utility contains links to the web page for the various resolutions steps (depending on the issue detected!) 
                    For Known Issues regarding the missing NOI derby column here
                   
  • The latest Impact Fix Pack installer automatically runs the same logic.

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Document Information

Modified date:
14 July 2022

UID

swg22004586