Troubleshooting
Problem
When using the Attach Format File workflow task in combination with a .html file and triCreatedSY field, the resulting output are not from the target record.
Symptom
The image shows that the time created and modified on the record name is the same time as the notification is sent. It should show the time that the User Account was created and modified.
Cause
This has been identified as a product defect under APAR IV96646
Environment
TRIRIGA Platform 3.4.2.5
Diagnosing The Problem
A. What do you need?
1. Workflow - When a specific user logs in (start condition on user's last name), a query runs to pull in the email recipient. A Notification record is created and a format file applied. Finally the notification is triggered.
2. Query - This is the query that returns a people record to send the notification to. The WF contains a Query task has a last name filter that will need to be updated to you.
3. Document record - this contains the format file which specifies two values. First, the Name of the the MyProfile record of the user that logged in. Second, what SHOULD be the triCreatedSY and triModifiedSY value of the user logging in.
B. Steps to Replicate
1. Ensure that the User Profile has an email address
2. Revise the Workflow Provided in the OM
A. In the Start Task >> Expression Box >> Add your Last Name as the value
B. In the Get My Own Email Task >> Filter Using >> Set the Right Data to your Last Name
3. Logout of TRIRIGA
4. Login to TRIRIGA
5. Wait a few minutes and an email notification will be sent.
The expected result should show the creation date of the My Profile. However, the time that is showing the time the notification has been sent.
Resolving The Problem
This issue is resolved by the fix for APAR IV96646: INCORRECT VALUE SHOWN FOR TRICREATEDSY WHEN INCLUDED ON HTML DOC ATTACHED TO A NOTIFICATION
Was this topic helpful?
Document Information
Modified date:
17 June 2018
UID
swg22004189