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Facility Assessment Analysis - Component Renewal Generation sping infinitely and reports error, Caused by: java.lang.OutOfMemoryError: Java heap space

Troubleshooting


Problem

In a clean environment, when creating the facility assessment analysis in TRIRIGA with a large number of years in the analysis (e.g 25), the component renewal generation begins to spin infinitely, generating too many component renewals and jamming the workflow queue.

Symptom

By reproducing the issue you will see an error in the server.log:


Caused by: java.lang.OutOfMemoryError: Java heap space.

Cause

This has been identified as a product defect under APAR IV94514

Environment

10.4.1/3.4.1.3

Diagnosing The Problem

STEPS TO REPRODUCE
1. Log in to TRIRIGA
2. Navigate to Maintenance > Facility Assessment > Create Facility Condition Analysis.
3. Create and save the record with the 6 locations listed in the record with ID 1000014.
4. Click on the Recalc Component Renewals action.
5. The page never returns with Component Renewals, and after a little while, you will begin seeing the errors mentioned.

Resolving The Problem

Apply the fix for APAR IV94514

IV94514: FACILITY ASSESSMENT ANALYSIS - INFINITE COMPONENT RENEWAL GENERATION
http://www-01.ibm.com/support/docview.wss?crawler=1&uid=swg1IV94514

[{"Product":{"code":"SSHEB3","label":"IBM TRIRIGA Application Platform"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"Version Independent","Edition":"Edition Independent","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
30 March 2022

UID

swg22003269