IBM Support

Gantt Chart date is set incorrectly if the Date Format is set to dd/mm/yy hh:mm:ss

Troubleshooting


Problem

Gantt Chart is incorrectly populated when using the Calendar Picker and when the Date format is DD/MM/YYYY hh:mm:ss in IBM TRIRIGA .

Symptom

When the user picks a date, it shows a different date after clicking the OK button in the calendar picker. See images below:




(Image 1 shows that the user opens the Calendar Picker and is going to select a date)


(Image 2 shows that the user picked a date and will click OK to continue)


(Image 3 shows that the desired date picked by the user is not the date selected in the Calendar Picker)

Cause

This has been identified as a product defect under APAR IV94518

Environment

TRIRIGA 10.5.2/3.5.2

Diagnosing The Problem

STEPS TO REPRODUCE
a. Pull up a Capital Project
b. Go to the Schedule tab
c. Display the Gantt Chart section
d. Create one task
e. Enter the name
f. Click on Planned Date calendar to enter the start date
g. In the calendar picker, ensure that the target year is in the bottom middle.
h. Select March 29th 2017 and click OK

Note: Ensure that the Date and Time Format is DD/MM/YY hh:mm:ss

Resolving The Problem

Apply fix for APAR IV94518 - GANTT CHART IS INCORRECTLY POPULATED WHEN USING THE CALENDAR
PICKER AND WHEN THE DATE FORMAT IS DD/MM/YYYY HH:MM:SS.

[{"Product":{"code":"SSHEB3","label":"IBM TRIRIGA Application Platform"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"Version Independent","Edition":"Edition Independent","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
30 March 2022

UID

swg22002630