IBM Support

Maximo VMMSYNC crontask won't synchronize 'employeeNumber' property to table

Troubleshooting


Problem

The VMMSYNC cron task has been configured and is running without error, but AD Property 'employeeNumber' is not synchronized to the Maximo tables as expected.

Cause

By default, there are some LDAP properties being defined as 'Unsupported' on the Websphere VMM side and 'employeeNumber' is one of them.


Unsupported properties will not be used by Websphere VMM and no query will be sent by Websphere VMM against the LDAP repository in order to fetch the property value.

Diagnosing The Problem

If you noticed the Maximo VMMSYNC crontask not synchronising the AD info to Maximo tables as expected, first turn on debug logging to make sure the crontask configuration is correct.

It is also possible to bring in custom attributes from Active Directory to Maximo tables by using VMMSYNC crontask.

Resolving The Problem

If you don't see any VMMSYNC-related errors in the debug log, you should follow the steps below to continue the troubleshooting.

  1. Back up the folders below from your Websphere server side \ibm\WebSphere\AppServer\profiles\ctgDmgr01\config\cells\ctgCell01\wim \ibm\WebSphere\AppServer\profiles\ctgAppSrv01\config\cells\ctgCell01\wim
  2. Access the Websphere Console, go to [Security]->[Global security], then click on the 'Configuration' button next to 'Federated repositories'. Next, click on the 'Repository Identifier' you configured on your environment.


  3. Click on 'Federated repositories property names to LDAP attributes mapping' located in the 'Additional Properties' section。

  4. You can see the LDAP attributes list. Please find 'employeeNumber' or the one you are interested in and select it, then click 'Delete'. Save the changes.



  5. Then go to menu [System administration] -> [Nodes]. Select the nodes from the table, and click on the 'Full Resynchronize' button. Ensure it finishes successfully.

  6. Now please restart the MXServer from the Websphere console.
  7. Wait till the VMMSYNC crontask completes running. Then check whether the 'employeeNumber' value is being synchronised to Maximo table column as expected.

[{"Product":{"code":"SSLKT6","label":"IBM Maximo Asset Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"System Related","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"Version Independent","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 June 2018

UID

swg22001435