IBM Support

Cannot upload Excel file without error in IBM Cognos Analytics 11.

Troubleshooting


Problem

When trying to upload an Excel Spreadsheet to use in an Analyis the green uploading status indicator turns red.

Symptom

Starting the upload of the Excel Spreadsheet quickly results in a Red Bar.


Cause

IIS has a Request Filter default file size limit of 30 MB.

Environment

Windows Server 2008 R2 with IIS 7.5 OR Windows Server 2012 R2 with IIS 8.5

Diagnosing The Problem

The Excel Spreadsheet uploads without issue if using the Dispatcher URI from the IBM Cognos Configuration tool.

Resolving The Problem

Use the IIS Manager

- Navigate to the Sites > Default Web Site > ibmcognos > bi folder and Highlight it in the Left Hand Side Connections window;

- Double Click the 'Request Filtering' Feature icon on the Right;

- In the Feature Menu on the Right Hand Side select 'Edit Feature Settings';

- In the Box 'Maximum allowed content length (Bytes)' enter in a larger size than the largest expected Excel Spreadsheet;


- Using the Services Applet in the Administration Tools, Stop and Start the World Wide Publishing Service;

- Clear the Browser's cache as per that products instructions;

The File size used for IIS Request Filtering should match or exceed the 'Size limit per upload of data' Setting in Cognos Manage > Configuration page of the UI.

[{"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Administration and Configuration v11x","Platform":[{"code":"PF033","label":"Windows"}],"Version":"11.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg22000505