Troubleshooting
Problem
After a user logs in to Netcool Impact application GUI, the user sees either a blank screen or a page with a link to this document.
Symptom
The user sees a blank page with an empty sidebar when logged in to the Impact GUI. An error message is reported to the user:
Error. Impact task deployment failed. To resolve the issue, please see http://www.ibm.com/support/docview.wss?uid=swg22000341
Cause
During the installation or upgrade of the Impact GUI server, the installer process re-deploys the Impact GUI application into the Liberty web server.
The re-deployment task relies on a HTTP REST call which can fail for several reasons:
- The REST call failed due to problems resolving the hostname or IP address of the GUI server.
- During an upgrade, invalid credentials were provided to the installer.
- The HTTP SSL request failed due to SSL configuration issues such as the use of TLS 1.3 protocol when only TLS 1.2 is supported.
Diagnosing The Problem
Log in to the Impact GUI.
Open the REST interface found at https://GUI_HOST:GUI_PORT/ibm/console/rest/deployments/details. This interface reports what pages are deployed to the GUI server.
If the installer failed to deploy the Impact GUI, you see no deployments:
{
"about": "https://hostname:16311/ibm/console/rest/deployments/details",
"allDeployments": [
],
"schemaGET": "https://hostname:16311/ibm/console/rest/deployments/details/schemaGET"
}
As a workaround, users can open the Impact welcome page directly by opening https://GUI_HOST:GUI_PORT/impactAdmin/jsp/impactAdminView.jsp
For fix pack 7.1.0.22 or 7.1.0.23, check if the following file exists:
IMPACT_HOME/wlp/usr/servers/ImpactUI/apps/blaze.war/WEB-INF/custom.properties
Verify the authorization.host property is correctly set.
authorization.host=impacthost
For more information about the property and how to troubleshoot it, see APAR IJ35798.
Resolving The Problem
Procedure to deploy the Impact GUI
Note: The Impact GUI server must be running.
Use the following command to deploy the Impact GUI. The command attempts to deploy the Impact GUI with the URL specified by the consoleRest parameter (https://localhost:16311/ibm/console/rest). If localhost isn't resolvable from the server, substitute the hostname in the consoleRest URL with an IP address or the fully qualified host name.
<IMPACT_HOME>/sdk/jre/bin/java -jar <IMPACT_HOME>/cli/cli.jar -deployUrl /impactAdmin/jsp/impactAdminDeploy.jsp -consoleRest https://localhost:<GUI_PORT>/ibm/console/rest -deployNotificationUrl https://localhost:<PORT>/impactAdmin/NCLogoutServlet -username <ADMIN_USER>-password <ADMIN_PASSWORD>
Where:
- IMPACT_HOME: Is the installed location of Netcool/Impact.
- GUI_PORT: Is the port number of the Impact GUI server (default is 16311).
- ADMIN_USER: Is the administrator username such as impactadmin.
- ADMIN_PASSWORD: Is the administrator password.
No restart of the server is needed. Clear the browser cache.
Following execution of the command, the following content is displayed upon loading this URL
https://GUI_HOST:GUI_PORT/ibm/console/rest/deployments/details
https://GUI_HOST:GUI_PORT/ibm/console/rest/deployments/details
{
"about": "https://hostname:16311/ibm/console/rest/deployments/details",
"allDeployments": [
{
"created": "2017-03-02T14:50:26-05:00",
"deployURL": "/impactAdmin/jsp/impactAdminDeploy.jsp?showAM=yes",
"deployment": "https://hostname:16311/ibm/console/rest/deployments/details?deploymentid=i1",
"deploymentID": "i1"
}
],
"schemaGET": "https://hostname:16311/ibm/console/rest/deployments/details/schemaGET"
}
If the deployment command fails, retry the command with the -verbose parameter. Capture the output and contact support.
<IMPACT_HOME>/sdk/jre/bin/java -jar <IMPACT_HOME>/cli/cli.jar -deployUrl /impactAdmin/jsp/impactAdminDeploy.jsp -consoleRest https://localhost:<GUI_PORT>/ibm/console/rest -deployNotificationUrl https://localhost:<PORT>/impactAdmin/NCLogoutServlet -username <ADMIN_USER>-password <ADMIN_PASSWORD> -verbose
Procedure to deploy the Impact GUI (7.1.0.26 or later)
Starting with the 7.1.0.26 release, the error page includes links to deploy the Impact GUI task or open the Impact GUI directly.
To deploy the Impact GUI from the browser, select the "Click here to repair the deployment" link. Refresh the browser after clicking the link. If the initial attempt does not work, clear the browser cache and restart the browser. Log in to the Impact GUI again and re-try the link.
Starting with the 7.1.0.26 release, the error page includes links to deploy the Impact GUI task or open the Impact GUI directly.
To deploy the Impact GUI from the browser, select the "Click here to repair the deployment" link. Refresh the browser after clicking the link. If the initial attempt does not work, clear the browser cache and restart the browser. Log in to the Impact GUI again and re-try the link.
To open the Impact GUI directly instead, select the "Click here to open the Impact console" link.
[{"Product":{"code":"SSSHYH","label":"Tivoli Netcool\/Impact"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Netcool\/Impact","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"},{"code":"PF002","label":"AIX"},{"code":"PF035","label":"z\/OS"}],"Version":"7.1.0","Edition":"Advanced","Line of Business":{"code":"LOB45","label":"Automation"}}]
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Document Information
Modified date:
17 June 2022
UID
swg22000341