IBM Support

Long running transactions are duplicated in Maximo after initial transaction times out

Troubleshooting


Problem

When a long running transaction times out, the message WTRN0006W is written to the log and the transaction is processed again leading to duplication of data in Maximo.

Symptom

The following message is written to the SystemOut log:


2017-02-23T14:38:31.480Z,maximoUAT,maxuatIF,[2/23/17 8:38:31:480 CST] 00000068 TimeoutManage I WTRN0006W: Transaction
0000015A6B66EB7700000001704C42E89CEFF036A26D3F5622ADE4DBFDB5744D247BB5C00000015A6B66EB7700000001704C42E89CEFF036A26D3F5622ADE4DBFDB5744D247BB5C000000001 has timed out after 120 seconds.

Cause

Transaction time-out value is set too low

Resolving The Problem

Increase the transaction time-out value to a value that represents the maximum time needed to load the largest transactions. 

In the administrative console, navigate to Servers > Server Types > WebSphere application servers > MXServer .



On the right side of the screen under Container Settings, click Container Services, then Transaction Service.

On the Total transaction lifetime time-out property, set the value (in seconds) to a number that is higher than the amount of time
it takes to process your largest transaction, or set the value to 0 so
there is no time-out applied. The default value is 120 seconds (2 minutes).

Save and synchronize your nodes.

If additional information is required, contact IBM Support.

[{"Product":{"code":"SSLKT6","label":"IBM Maximo Asset Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"MEA: Generic","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"7.5;7.6","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 June 2018

UID

swg21999788