IBM Support

Data is corrupted when importing a large amount of records with errors

Troubleshooting


Problem

If you import a large number of records that contain corrupted characters into Maximo Asset Management and then export the records to be corrected, a new error is introduced when the records are downloaded to a local file system.

Symptom

The extracted files are corrupted.

Cause

The system property mxe.int.maxexrtactdocs identifies how many downloaded records to accept in a single temporary file when an extract file is created.

For example, if the system property value is set to 500, then 500 records are downloaded to a temporary file and the next 500 records are downloaded to an additional temporary file until all records have been downloaded. The temporary files are then concatenated into one error extraction file.

If errors are present in the records, the original error in the 501st and following records is not saved in UTF8 format, which corrupts the data in the records.

Resolving The Problem

In the System Properties application, set the value of the mxe.int.maxextractdocs property to be greater than the number of records will be extracted so that only one temporary file is created.

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Document Information

Modified date:
17 June 2018

UID

swg21999641