Troubleshooting
Problem
TRIRIGA CAD Integrator plugin is failing to login using the proxy settings. The software returns an error: 'Login Failed. Contact IBM Software Support.'
Symptom
After installing the CAD Integrator plugin for version 12.1.4, it is failing to login to TRIRIGA using the proxy settings. The software returns an error:
Login Failed. Contact IBM Software Support.
The software is trying to connect to several IP addresses or URLs including Amazon Web Services (AWS) which are being dropped at the firewall.
Cause
Our investigation suggests the issue is related to the 3rd party libraries for HttpClient 4.3.1 described here: https://issues.apache.org/jira/browse/HTTPCLIENT-1431
It appears this is a known problem with the older HttpClient library which CI uses for communication with TRIRIGA.
Diagnosing The Problem
We confirmed that connection from TRIRIGA CAD Integrator works fine when bypassing the proxy. Upon review of the CI.log file we see the following error:
ERROR [com.tririga.ci.login.LoginServiceImpl](pool-1-thread-10) Login failed:
java.lang.IllegalStateException: Socket factory must implement SchemeLayeredSocketFactory.
Researching this error led us to look at the HTTPClient libraries.
Resolving The Problem
Upgrade CAD Integrator to TRIRIGA CAD Integrator version 12.1.5. Note that this might require an upgrade to your TRIRIGA Platform. Please check the Compatibility Matrices linked below.
Related Information
Was this topic helpful?
Document Information
Modified date:
15 August 2018
UID
swg21999493