IBM Support

Direct Print does not work from a Maximo Cluster with no BROS enabled

Troubleshooting


Problem

After setting up a Maximo cluster Direct Printing seemed to have stopped working. Customer is not using a BROS, but mxe.report.birt.viewerurl is populated and cannot be changed.

Symptom

The users sees this error. 7606 Print button returning Error 400: SRVE0295E: Error

Cause

The customer may have used the Tivoli Process Automation Suite config tool to set up the Maximo cluster. If they happened to enable 'reporting', they have inadvertently set the cluster up as a Birt Report Only Server.

Environment

Clustered environments

Diagnosing The Problem

Open the Maximo.ear and examine the maximo.properties file. Search for the property mxe.report.birt.viewerurl. If it exists, this is the issue.

Resolving The Problem

Edit the maximo.properties file, remove the reference to viewerurl, move the file back into the ear and redeploy.

[{"Product":{"code":"SSLKT6","label":"IBM Maximo Asset Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Report Admin","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"7.6;7.6.0.5;7.6.0.6","Edition":"All Editions","Line of Business":{"code":"LOB59","label":"Sustainability Software"}},{"Product":{"code":"SSLKT6","label":"IBM Maximo Asset Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 June 2018

UID

swg21997481