Troubleshooting
Problem
After setting up a Maximo cluster Direct Printing seemed to have stopped working. Customer is not using a BROS, but mxe.report.birt.viewerurl is populated and cannot be changed.
Symptom
The users sees this error. 7606 Print button returning Error 400: SRVE0295E: Error
Cause
The customer may have used the Tivoli Process Automation Suite config tool to set up the Maximo cluster. If they happened to enable 'reporting', they have inadvertently set the cluster up as a Birt Report Only Server.
Environment
Clustered environments
Diagnosing The Problem
Open the Maximo.ear and examine the maximo.properties file. Search for the property mxe.report.birt.viewerurl. If it exists, this is the issue.
Resolving The Problem
Edit the maximo.properties file, remove the reference to viewerurl, move the file back into the ear and redeploy.
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Document Information
Modified date:
17 June 2018
UID
swg21997481