IBM Support

Fix Pack または Hotfix が "Lotus Notes/Domino or a Notes/Domino related process is still running." エラーでインストールできない

Technote(トラブルシューティング)


問題

IBM Domino サーバーに Fix Pack もしくは Hotfix をインストールしようしたところ、以下のエラーでインストールできません。


    Lotus Notes/Domino or a Notes/Domino related process is still running.
    Please close it before pressing OK to continue.

または
    Lotus Notes/Domino or a Notes/Domino related process is still running.
    Please close it before pressing OK to continue.
    On systems with UAC you need to Run as administrator

原因

この現象が発生する原因は、以下のいずれかの場合です。


1. IBM Domino サーバー関連のプロセス(nsd.exe も含めて主に "n" で始まるプロセス、scontroller.exejconsole.exe)およびサービスが終了していない。
2. バックアップソフト、もしくはウィルススキャンソフトが IBM Domino サーバーのファイルにアクセスしている。
3. Windows Management Instrumentation サービスが稼動している。
4. Fix Pack もしくは Hotfix のインストーラーを管理者権限で実行していない。
5. Fix Pack もしくは Hotfix のインストーラーが OS のプロパティにて「読み取り専用」にチェックされている。
6. Windows 側(OS 側)で、インストール先のフォルダに書き込み禁止権限が設定されている。

解決方法

上記のそれぞれの原因に対する対応策は、以下の通りです。


1. タスクマネージャーで IBM Domino サーバー関連のプロセス(nsd.exe も含めて、主に "n" で始まるプロセス)およびサービスを終了する。
2. IBM Domino サーバーのファイルにアクセスしているソフトを終了する。
3. Windows Management Instrumentation サービスを停止する。
4. Fix Pack もしくは Hotfix のインストーラーを管理者権限で実行する。
5. Fix Pack もしくは Hotfix のインストーラーに対して、OS のプロパティで「読み取り専用」のチェックを外す。
6. インストール先のフォルダに書き込み権限を追加する。

上記の対応策を実施してもインストールできない場合、以下の対応策を実施してください。

A. Microsoft 社の Process Explorer で IBM Domino サーバーのファイルにアクセスしているプロセスを探す。

  1. Microsoft 社のサイトから Process Explorer をダウンロードし、zip ファイルを展開する。
  2. 事象を発生させる。
  3. procexp.exe を実行する。
  4. メニューから [Find] - [Find Handle or DLL...] を実行する。
  5. Handle or DLL substring: に IBM Domino サーバーのプログラムディレクトリ、もしくは Data ディレクトリを入力する。
  6. プロセスがリストされた場合、リストされたプロセスを確認し、そのプロセスを終了した上で、再度 Fix Pack もしくは Hotfix をインストールする。

B. Windows をセーフモードで起動し、Fix Pack もしくは Hotfix をインストールする。

Document information

More support for: IBM Domino

Software version: 8.5, 9.0

Operating system(s): Windows

Software edition: All Editions

Reference #: 1997183

Modified date: 10 February 2017


Translate this page: