IBM Support

Understanding Save, Auto-save, Publish, Auto-publish, and Copy

Technote (FAQ)


Question

In IBM Docs, users have the option to save, auto-save, publish, auto-publish, or copy a file. How are these options different?

Answer

  • Auto-save and Save

    When you edit a file in IBM Docs, the changes are auto-saved every 30 seconds. But the auto-save only saves the changes as draft in the IBM Docs server, so the draft is always up-to-date containing all the changes. It does not create any versions in the Files application. This means that only owners and editors can see the changes while in editing mode, and changes are not displayed in viewing mode. Moreover, the auto-saved changes cannot be downloaded.

    Every time that auto-save finishes, the following message is displayed. 
     

    Besides auto-save , you can click File > Save from the main menu at any time. But, behaving in the same way as auto-save, the Save option only saves a draft.

    Note: In order for Readers to view or download the file, it must be published as a version. Now let's look at the auto-publish and publish options.

  • Auto-publish and Publish

    In order for readers to see or download a draft or edits made in IBM Docs, a new version of the file must be published. In single-editing mode, by default, the setting File > Publish Automatically creates a version each time you close the document. Owners and editors can create a version anytime by clicking File > Publish Now.

    • How does automatic publishing work?
      Auto-publish can be enabled or disabled by the File > Publish Automatically menu item. When enabled, in single-editing mode, after making changes, every time you close the document, a new version is created (making changes available to those you have shared the file with as readers). During a simultaneous group editing session, the new version is created after the last co-editor closes the document.

      Note: If the previous version was published more than one hour ago, both the previous version and new version are listed in the VERSIONS tab. Otherwise, the new version will directly replace the previous one and you won't be able to see the previous version in the VERSIONS tab.

    • Do I need to save the draft in between versions?
      The draft is always saved automatically, including when you suddenly close the document. Even during a group editing session, a browser crash is the only way that data could be lost.
    • What if I want to publish a version now, without closing the document?
      From the menu, you can click File > Publish Now at any time. Creating a version in this way is useful when think you might want to revert to the current state of the document before making more changes. Any co-editor can publish the file in this way. Note that when the last co-editor closes the file, another version is still created.

      Tip: Files that you upload from Microsoft Office or OpenOffice are always published in their original format. For files that you create online, or for .txt or .csv files, you can change the default file format that the file will be published to in Tools > Preferences.

      Whether a file is published automatically or manually, a new version of the file is displayed in the Files application as soon as the Files window is refreshed, and notifications are sent to people who are following the file.

  • Copy

    Use Copy when you want to save a file with a new name and open it in a separate window.

    Click File > Copy. Type a new file name and then click OK. The new document opens in a separate window and is saved in Files list.

    Note: If you use the Copy command to save a .doc, .docx, or .odt file, the file that is created keeps its original format. For a .txt file, you can set a preferred format by clicking Tools > Preferences and then saving the file.

Document information

More support for: IBM Connections Docs
Common Services

Software version: 2.0

Operating system(s): Linux, Windows

Reference #: 1997113

Modified date: 12 January 2017


Translate this page: