Question & Answer
Question
What are the known issues with IBM Spectrum Protect™ Operations Center V8.1.0?
Answer
The following issues have been identified in Version 8.1.0 of the Operations Center:
Log-in and general issues
- After you install or upgrade the Operations Center, you are unable to view the login page
- The login screen shows only a generic authorization failed message
- You cannot add customized text to the login screen
- Operating system requirements for Linux on System z are not documented
Servers
- Copy space details for servers do not include space that is used in container-copy pools
- The Connect Spoke Server wizard returns errors if you specify a server that is already defined to the hub server
Symptom
You installed or upgraded the Operations Center. In a web browser, you enter the address for the Operations Center, but the browser does not display the login screen. Instead, the following error is displayed:
Error 400: SRVE0295E: Error reported: 400
Cause
The web server of the Operations Center runs as a service and starts automatically. Sometimes, because the service hangs, a duplicate service might be started. Other times, a server might continue running after you stop the Operations Center, and a duplicate service starts when you start the Operations Center. When multiple instances of the service are running, it can cause unpredictable results in the Operations Center. When you reinstall or upgrade the Operations Center, for example, a running service can interfere with the installation process.
Solution
Complete the following steps to diagnose and resolve this problem:
1.
- If you reinstalled or upgraded the Operations Center, review the web-server log file, console.log, to determine whether errors were reported during the installation of Operations Center components. Errors might be reported in this file even if the Installation Manager completed successfully.
The console.log log file is located in the following directory:
installation_dir/ui/Liberty/usr/servers/guiServer/logs
Where installation_dir represents the directory in which the product is installed.
If no errors are recorded in the file, you need to restart the web server after you end web server processes. If errors are reported, you need to uninstall and reinstall the Operations Center after you end web server processes.
- Depending on your operating system, complete the following steps to end all running instances of the guiServer process.
- On a UNIX or Linux system, complete the following steps:
a) Enter the following ps command to determine whether multiple instances of the guiServer process are running on the computer where the Operations Center is installed:
ps -ef | grep guiServer - On a Windows system, end all running instances of the guiServer process by rebooting your system.
b) End all running instances of the guiServer process by using the kill command, or by rebooting your system.
3.
- If you newly installed the Operations Center, or if you reinstalled or upgraded the Operations Center and the console.log file did not contain installation errors, restart the web server as described in the following Knowledge Center topic:
https://www.ibm.com/support/knowledgecenter/SSEQVQ_8.1.0/srv.install/t_oc_inst_web_server_startstop.html
- If you reinstalled or upgraded the Operations Center, and the console.log file did contain installation errors, uninstall, and reinstall the Operations Center.
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Symptom
You cannot log in to the Operations Center. The login screen displays the message "Authorization failed", but no further information is supplied. You are certain the correct user ID and password were entered, and do not understand why authorization failed.
Cause
You log in to the Operations Center by using an administrator ID that is registered on the hub server. Depending on the configuration of the hub server and the definition of the administrator ID, the password is either authenticated by the hub server or by using a Lightweight Directory Access Protocol (LDAP) server. Authentication by using an LDAP server requires communication that is encrypted by the SSL or TLS protocol.
If you are certain you entered the correct ID and password, the problem might be that the administrator ID requires authentication by using an LDAP server, and the Operations Center is not configured for secure communication.
Solution
To diagnose the problem, you can take the following actions:
Although the Operations Center reports only that authentication failed, more specific information is reported to the server console and activity log of the hub server. Query the activity log for more information about why the hub server did not authorize the administrator ID.
If the administrator ID requires authentication by using an LDAP server, and the Operations Center is not configured for secure communication, the activity log contains the following error.
ANR1888W Session session number for node node name (client platform) refused - client requires SSL connection with this server.
To determine whether the administrator ID requires LDAP authentication, enter the following command on the hub server:
query admin admin_name format=detailed
The Authentication field in the command output indicates whether local or LDAP authentication is required for this administrator ID. LDAP authentication requires SSL or TLS communication.
To determine whether the hub server is configured for LDAP or local authentication, complete the following steps by using an account that is able to log in to the Operations Center.
- On the Servers page, select the hub server, and click Details.
- On the details notebook, click the Properties tab.
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Symptom
The documentation describes a procedure for adding customized text, such as your organization's Terms of Use of the software, to the login screen of the Operations Center. You followed the instructions, and created a file that is named loginText.html that contains the text that you want to add to the login screen. However, the customized text does not appear on the login screen.
Cause
Although the documented procedure for adding customized text to the login screen is correct for earlier versions of the Operations Center, it is not correct for Version 8.1.0.
Solution
There is no workaround for this known issue. You cannot add customized text to the login screen in Version 8.1.0.
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Symptom
You want to install and run the Operations Center on Linux on System z, but you cannot find the operating system requirements.
Cause
The operating system requirements for Linux on x86_64 systems are documented, but the requirements for Linux on System z are not documented.
Solution
Review the server requirements for Linux on System z, which are the same as the Operations Center requirements. You can run the Operations Center on Linux on System z (s390x 64-bit architecture) with the following operating systems:
- Red Hat Enterprise Linux 7.1
- SUSE Linux Enterprise Server 12
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Symptom
You are viewing the capacity used information for a server on the Summary tab of its Details notebook. The copy space used measurement is smaller than you expect. Data in directory-container storage pools that are defined to the server are regularly protected to container-copy storage pools to create tape copies. However, the capacity that is used in the container-copy storage pools is not reflected in the server's copy space used measurement.
Cause
The capacity used information on the Summary tab of the server Details notebook includes only data in copy storage pools. Capacity in container-copy storage pools is not included.
Solution
View the capacity for container-copy storage pools on the Storage Pools page. You can filter the Storage Pools table by Type and Server to show only the container-copy storage pools that are defined to a particular server.
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Symptom
You are adding a spoke server to the hub server by using the Connect Spoke Server wizard. The wizard indicates that server-to-server communication failed, and returns the following error:
ANR1700E Unable to resolve 'route information' to any server(s).
Cause
In the Connect Spoke Server wizard, you specified a server that was already defined to the hub server by using the DEFINE SERVER command.
Solution
Open the Servers page and check if the server is already listed in the servers table, but has a status of "Unmonitored." This status means that although an administrator defined this server to the hub server by using the DEFINE SERVER command, the server is not yet configured as a spoke server. If the server is defined but unmonitored, do not use the Connect Spoke Server wizard. Instead, click the server to highlight it, and in the table menu bar, click Monitor Spoke.
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Document Information
Modified date:
17 June 2018
UID
swg21993772