IBM Support

TRIRIGA CAD Integrator will not complete Full Sync

Troubleshooting


Problem

Unable to perform a Full Sync of CAD Drawings if there are any people assigned to the spaces.

Symptom

CI.log error:



ERROR [com.tririga.ci.sync.SyncServiceImpl](pool-1-thread-2) Sync failed.
com.tririga.ci.error.CiRuntimeException: com.tririga.ci.remote.shared.error.CiSharedException: Attach associated object could not find the association to use.

Cause

CAD Hierarchy for custom configuration is not mapped correctly for triSubSpace.

Resolving The Problem

Custom Business Objects and Forms were created for all property hierarchy items. We found that the existing triSubSpace CAD Hierarchy Node for triSubSpace was not changed. It still references "Space Mapping", instead of "cstSpace Mapping". This means both Space mappings are part of the Application Definition (which have different forms). This was causing the full sync to fail.

Updating the triSubSpace hierarchy node to point to the cstSpaceMapping will resolve this error.

See Image:


[{"Product":{"code":"SSQTNT","label":"IBM TRIRIGA CAD Integrator\/Publisher"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"12.0;12.0.1;12.0.2;12.0.3;12.1;12.1.1;12.1.2;12.1.3;12.1.4","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
15 August 2018

UID

swg21992102