IBM Support

Is IBM FileNet IDM Desktop 4.0.3 and its associated components supported under Windows 10?

Question & Answer


Question

The system requirements page for FileNet IDM Desktop 4.0.3 does identify Windows 10 as being supported but does that also include any components installed by this version of the software?

Cause

There is a discrepancy in the compatibility reports. The FileNet IDM Desktop 4.0.3 is shown as supported under Windows 10 but FileNet IDM Desktop installs the Image Services Toolkit.  The system requirements information for ISTK 4.1.2 FP22 does not indicate support for Windows 10 and yet this version of the component is installed as part of the FileNet IDM Desktop 4.0.3 installation.

Answer

You must install the IBM FileNet Image Services Toolkit 4.2.0.13-ISTK-FP0013 Fix Pack or later in order for this component to be supported under Windows 10 as per this extract from the Image Services Toolkit FP13 Readme file:

Introduced in Image Services Toolkit 4.2.0.13-ISTK-FP0013
Support for Windows 10. Refer to IBM Tech Note #1980830 for the ISTK installation procedure for Windows 10.
http://www.ibm.com/support/docview.wss?uid=swg21980830

So FileNet IDM Desktop 4.0.3 is supported under Windows 10 but you must also install an updated version of the Image services Toolkit for full Windows 10 support.

[{"Product":{"code":"SS5USE","label":"FileNet IDM Desktop\/WEB Services\/Open Client"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"IDM Desktop","Platform":[{"code":"PF033","label":"Windows"}],"Version":"4.0.3","Edition":"All Editions","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21991801