IBM Support

Cognos scheduled report in Excel 2007 format of attachment file detected as a JAR file within MS OFFICE 365 mail server

Troubleshooting


Problem

When customer run the Schedule it completes successfully but user do not get any email. Cognos scheduled report in Excel 2007 Emails attachement file detected as JAR file within OFFICE 365 preventing them from being sent through the mail server

Symptom

User get emails without Excel output attachments after run the Scheduled report (no issue or error message from Cognos)

Cause

Office 365 server is looking at the File Signature of files being emailed as attachments and recognizes that Cognos excel output file is a JAR file. Office 365 is expecting that the .xlsx file should be the exact File Signature of a .xlsx file. Mail server is blocking executable content.

Diagnosing The Problem

Open xlsx excel attachment files within the Hex Editor tool

Cognos Excel 2007 output file has the first set of hex numbers (50 4B 03 04 14 00 08 00 08 00 ) which indicate that this is a JAR file (not a xlsx file).

The first set of Standard format of XLSX hex numbers is (50 4B 03 04 14 00 06 00)

Resolving The Problem

The following Advanced Server Configuration Setting is required to enable this functionality.

In Server Administration, add RSVP.EXCEL.EXCEL_2007_FILE_ZIP True parameter to ReportService and BatchReportService.

When the setting of "RSVP.EXCEL.EXCEL_2007_FILE_ZIP" is set to "True", then the first 8 bytes are changed to "50 4b 03 04 14 00 0a 00". (Default setting is "false")


0.Open Cognos Connection.
1.Click Launch menu in the portal and select Cognos Administration
2.Click Configuration Tab
3.Select Dispatchers and Services from the menu on the left side
4.Click the dispatcher to configure
5.Select more in action menu for ReportService
6.Select setting from Set properties
7.Find the property that is named Advanced Settings, and Click the Edit
8.Check Override the settings acquired from the parent entry
9.In the first empty set of boxes, type in the parameter name RSVP.EXCEL.EXCEL_2007_FILE_ZIP and set the value to TRUE
10.Press OK.

11.Back to the dispatcher to configure
12.Select more in action menu for BatchReportService
13.Select setting from Set properties
14.Find the property that is named Advanced Settings, and Click the Edit
15.Check Override the settings acquired from the parent entry
16.In the first empty set of boxes, type in the parameter name RSVP.EXCEL.EXCEL_2007_FILE_ZIP and set the value to TRUE
17.Click OK.
18.Restart the service.

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Cognos Administration","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"10.2;10.2.1;10.2.2","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21990961