IBM Support

Server does not start after upgrade to latest version on Windows 2008 R2 x64

Troubleshooting


Problem

IBM Spectrum Protect Server does not start after an upgrade to version 7.1.6.x or 7.1.7.x claiming a problem with Kernel32.dll library.

Symptom

After a successful upgrade of IBM Spectrum Protect server to version 7.1.6.x or 7.1.7.x on Windows 2008 R2 x64 the following popup error is reported when manually starting the application:

"The procedure entry point AddDllDirectory could not be located in the dynamic link library Kernel32.dll"

As result the IBM Spectrum Protect server does not start.

Cause

The problem is caused by the missing MS patch number KB2533623 for Windows 2008 R2 x64

Environment

Windows 2008 R2 x64

Diagnosing The Problem

Ensure that the MS patch is installed on the system.

The following command (ran as an Administrator) can be used to check if it is installed:



wmic qfe get hotfixid | find "KB2533623"

Example:
C:\Users\Admin>wmic qfe get hotfixid | find "KB2533623"
KB2533623

C:\Users\Admin>

Resolving The Problem

If the MS patch is not installed, contact the system administrator and ask for the patch to be installed.


The IBM Spectrum Protect server will start normally after the installation of the patch and the required reboot.

[{"Product":{"code":"SSSQWC","label":"Tivoli Storage Manager Extended Edition"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.1","Edition":"All Editions","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg21990932