IBM Support

Inventory locking in consolidateToShipment API

Troubleshooting


Problem

Attempts to run consolidateToShipment transaction locks YFS_INVENTORY_ITEM in IBM Sterling Order Management.

Cause

The record is locked to update as part of shipment consolidation

Diagnosing The Problem

The table being locked when there are no changes required for supply and demand.

Resolving The Problem

The function called to lock the order is locked not to check availability, but necessarily none the less. In 9.3 product always locked the shipment first since shipments can go across orders.

  • Sample Scenario:
    Consider item1 and item2 belong to order2 and order1.
    A shipment is created for these two orders.
    Product lock the items up front because it doesn't know at this point what inventory picture changes are going to be made and wants to avoid deadlock.

This feature is not available in 9.3, in 9.3, this is going to lock unless the item is "hot", as part of a Hot Sku implementation.

[{"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Documentation","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"9.3","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21990915