IBM Support

Not able to login to CA 11.0.X, ERROR 500

Troubleshooting


Problem

When attempting to login an error is presented. Error: 500 User Profile Service : Internal Server Error
Caused by: post to v1/login"

Symptom

Error: 500
User Profile Service : Internal Server Error<br> Caused by: post to
v1/login"

From the logs.

[8/24/16 1:42:59:715 CDT] 0000007a
com.ibm.ws.webcontainer.util.ApplicationErrorUtils E
SRVE0777E: Exception thrown by application class
'org.apache.wink.server.internal.RequestProcessor.handleRequest:195'
javax.servlet.ServletException: java.lang.NoClassDefFoundError:
org.bouncycastle145.asn1.ASN1Sequence


Caused by: java.lang.NoClassDefFoundError:
org.bouncycastle145.asn1.ASN1Sequence


Cause

bcprov-jdk14-145.jar is missing from ~cognos~\jre\lib\ext

Resolving The Problem

Add missing file bcprov-jdk14-145.jar to ~cognos~\jre\lib\ext

[{"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"11.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21990857