IBM Support

Data Server Manager (DSM) does not show historical data

Question & Answer


Question

Why Data Server Manager does not show historical data for the monitored database?

Cause

There are some scenarios where DSM does not show historical data (Historical SQL Monitoring) for a monitored database.
Here is a list of the most common scenarios:
1. The browser's history/cache contains old code affecting the display of the data

2. The web browser (or version) is not supported

3. Check your Database Connection page, click on Settings --> Manage Connections:

The Capabilities column needs to be set to "ENTERPRISE" to collect historical data. DSM Base Edition does not allow keeping historical data.

Answer

Here are the recommendation for those common scenarios:
1. Clean up the browser's history/cache and run DSM again.

2. Install or upgrade to a supported web browser version and access DSM again.

3. DSM changed licensing since V2.1:
Currently, IBM Data Server Manager 2.1.x automatically activates its enterprise capabilities when connecting to any of the following DB2 edition servers:

  • IBM Db2 Advanced Enterprise Server Edition, version 11.1, 10.5, 10.1, 9.7
  • IBM Db2 Advanced Workgroup Server Edition, version 11.1, 10.5
  • IBM Db2 Express Edition, Workgroup Edition, or Enterprise Edition databases, version 10.5.0.5 and higher,with the Performance Management Offering installed
  • IBM Db2 Performance Management Offering 11.1, 10.5
  • IBM DB2 Developer Edition, version 11.1, 10.5, 10.1, 9.7
  • IBM Db2 Developer-C Edition 11.1(starting in DSM V2.1.5 )
  • IBM Db2 Direct Advanced Edition, version 11.1
  • IBM Db2 Hosted Advanced Edition
  • IBM Db2 on Cloud
  • IBM Db2 Warehouse on Cloud
  • IBM Db2 Warehouse 1.11
  • IBM dashDB Local 1.10,1.9,1.8,1.7,1.6,1.5,1.4

When using IBM Data Server Manager to monitor a database with a DB2 Express Edition, DB2 Workgroup Edition or DB2 Enterprise Edition databases, version 10.5.0.4 or lower, or any DB2 Edition Restricted license, the DSM License Activation Kit needs to be installed to activate the enterprise capabilities.

You can find the DB2 license information by using the DB2 db2licm -l command.

If the database is 10.5.0.5 or higher and the Capabilities column still shows "BASE" as shown in the picture above, make sure that DB2 Edition field is correctly set it up:


To update the DB2 Edition, either click on Unknown word, or select the database, and click on Validate Configuration button:


Important Note:
To confirm if the DSM License Activation Kit has been installed successfully, check the about.txt file under the <DSM_install>/logs directory.
If the database is activated automatically in Database Connection or if the DSM License Activation Kit is installed, the capability of each connection will be saved in the repository tables, and the Enterprise capabilities will be enabled for the database connections.
Now, if the database is not activated automatically and the DSM License Activation Kit needs to be installed, the Capabilities column might still show "BASE". When clicking on the "DB2 Edition" column for that database connection, a request will be sent out to check whether DSM License Activation Kit has been applied. If yes, then the capability of this connection will be shown as "ENTERPRISE", but this information won't be updated into the repository tables.
Once the Database Connection page is refreshed, the Capability of such connection will change back to "BASE".
From functionality perspective, this won't have any impact on the usage of DSM features.

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Document Information

Modified date:
19 October 2018

UID

swg21990109