IBM Support

Data Server Manager (DSM) shows zero values as metrics

Troubleshooting


Problem

Why Data Server Manager (DSM) keeps showing zeros as metrics?

Cause

One or more monitored database configuration parameter does not have the required configuration to capture the in-memory metrics data.

Diagnosing The Problem

Check the database configuration parameters on the monitored database.

Connect to the monitored database and run the following DB2 command:

- db2 GET DB CFG

Look for these configuration parameters:


MON_REQ_METRICS
MON_ACT_METRICS
MON_OBJ_METRICS
MON_RTN_DATA

The configuration needs to have either BASE or EXTENDED to avoid this issue.


The minimum value should be set to "BASE", which is enough to collect performance data.


Resolving The Problem


If the values are not set to either BASE or EXTENDED, connect to the monitored database having the issue using an userid who has the privileges to update the database configuration.
Run the following DB2 command depending on the configuration which does not have either BASE or EXTENDED:
- db2 UPDATE DB CFG USING MON_REQ_METRICS BASE
- db2 UPDATE DB CFG USING MON_ACT_METRICS BASE
- db2 UPDATE DB CFG USING MON_OBJ_METRICS BASE
- db2 UPDATE DB CFG USING MON_RTN_DATA BASE

For additional information: Data Server Manager - Setting database parameter values

[{"Product":{"code":"SS5Q8A","label":"IBM Data Server Manager"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"},{"code":"PF002","label":"AIX"}],"Version":"2.1.3;2.1.2;2.1.1;2.1;1.1.2;1.1.1;1.1;2.1.4;2.1.5","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
16 June 2018

UID

swg21990104