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Sametime Connect 9.0.1 (stand-alone) client on 32 or 64 bit machine logs in and can see awareness, but errors out when clicking someone in buddy list to chat with: "Failure to initialize chat with <user name> (<email address). please close othe

Technote (troubleshooting)


Problem

Double clicking a contact in your Sametime Connect client's buddy list does not open the chat dialog box, and you receive the following error message:

The chat dialog box never opens in Windows after double clicking the person you want to chat with, and you receive the following error message:

"Failure to initialize chat with <user name> (<email address). please close other chats and applications and try again.


Symptom

Sametime Connect chat logs shows:

If checking the client logs, the following exceptions appears:
Exception from MozillaBrowser
java.lang.Exception: XPCOMGlueStartup failed. rc = -2147467259
at com.ibm.rcp.dombrowser.browser.MozillaBrowser.<init>(Unknown Source)

Unexpected exception constructing Browser:
com.ibm.rcp.dombrowser.browser.DOMBrowser
java.lang.reflect.InvocationTargetException
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

Caused by: org.eclipse.swt.SWTError: No more handles [XPCOMGlueStartup failed]
(java.lang.Exception: XPCOMGlueStartup failed. rc = -2147467259)

Windows OS Event Viewer / Applications shows:
Application event log error - Source SideBySide - Event ID 33

Activation context generation failed for "C:\Program Files
(x86)\IBM\Sametime
Connect\rcp\eclipse\plugins\com.ibm.rcp.xulrunner.runtime.win32.x86_9.0.
2.20160525-0358\xulrunner\xul.dll". Dependent Assembly
Microsoft.VC80.CRT,processorArchitecture="x86",publicKeyToken="<xxxxxxxxxxxxxxxx>"

",version="8.0.50727.6195" could not be found.
Please use sxstrace.exe for detailed diagnosis

Cause

The Sametime Connect client 9.0.1 version has a dependency of a Microsoft patch that it requires.

See the 'Resolving the problem' section below.


Resolving the problem

IMPORTANT - Regardless of the operating system being 32 or 64 bit, the 32 bit patch is what is needed to correct this issue. Installing the 64 bit patch on a 64 machine will NOT fix this issue.


1) Either click this link: https://www.microsoft.com/en-us/download/confirmation.aspx?id=26347
which will automatically show this dialog box - provided the users in their environment can hit it.



2) Exit the Sametime Connect client.

3) Once they've saved the file locally they can execute the file and follow the installation instructions for applying the Microsoft patch:
"Microsoft Visual C++ 2005 Service Pack 1 Redistributable Package MFC Security Update "

4) Reboot the workstation to ensure the patch is finished installing.

Document information

More support for: IBM Sametime
Connect client

Software version: 9.0.1

Operating system(s): Windows

Software edition: Standard

Reference #: 1988925

Modified date: 11 November 2016