IBM Support

Security Bulletin: Apache Commons FileUpload Vulnerability affects WebSphere Application Server (CVE-2016-3092)

Security Bulletin


Summary

Apache Commons Fileupload vulnerability affects WebSphere Application Server and WebSphere Application Server Hypervisor Edition.

Vulnerability Details

CVEID: CVE-2016-3092
DESCRIPTION:
Apache Tomcat is vulnerable to a denial of service, caused by an error in the Apache Commons FileUpload component. By sending file upload requests, an attacker could exploit this vulnerability to cause the server to become unresponsive.
CVSS Base Score: 5.3
CVSS Temporal Score: See https://exchange.xforce.ibmcloud.com/vulnerabilities/114336 for the current score
CVSS Environmental Score*: Undefined
CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L)

Affected Products and Versions

The following Versions of WebSphere Application Server and IBM WebSphere Application Server Hypervisor Edition may be affected:

  • Liberty
  • Version 9.0
  • Version 8.5
  • Version 8.0
  • Version 7.0
This vulnerability also affects the following versions of WebSphere Extended Deployment Compute Grid:
  • Version 8.0 on WebSphere Application Server Version 7 or Version 8

Remediation/Fixes

Apache Commons FileUpload used by the Administrative Console and WebContainer in WebSphere Application Server and batch processing in IBM Compute Grid may be vulnerable to a denial of service. You may need to apply more than one interim fix to get full protection.


The recommended solution is to apply the Fix Pack or PTF for each named product as soon as practical. There are 4 separate interim fixes that may need to be applied, links are provided below to fix central:

APARs
PI65218 for the Administrative Console - not vulnerable in Liberty
PI65853 for the Web Container - not vulnerable prior to Version 8
PI65815 Administering batch jobs using WebSphere Java Batch for Version 8.5 and 9
PI65919 Administering batch jobs in Compute Grid for Version 7 and 8

IMPORTANT NOTE:
You could see a warning message when you try to upgrade to 8.5.5.11 or 9.0.0.1 fixpack if you have installed the interim fix for PI65815. If you see this warning message, you may ignore it since the fix is included in the fix pack.

WARNING: One or more fixes will be uninstalled when IBM WebSphere Application Server is updated to 8.5.5.11 (or 9.0.0.1). The update does not address issues that were resolved previously by the maintenance packages. The problems might return if fixes for the following issues are not reapplied or have new fixes applied to prevent the problems from returning.
- PI65815 in the fix package 8.5.5.1-WS-WAS-IFPI65815.


For IBM WebSphere Application Server and IBM WebSphere Application Server Hypervisor Edition:

For Liberty:

  • Upgrade to minimal fix pack levels as required by interim fix and then apply Interim Fix PI65853
-- OR
  • Apply 3Q Fix Pack (16.0.0.3), or later.

For V9.0.0.0 -- OR
  • Apply Fix Pack 1 (9.0.0.1), or later.

For V8.5.0.0 through 8.5.5.10 Traditional:
  • Upgrade to minimal fix pack levels as required by interim fix and then apply Interim Fix PI65218 and PI65853
-- OR
  • Apply Fix Pack 11 (8.5.5.11), or later.

For V8.0.0.0 through 8.0.0.12:
  • Upgrade to minimal fix pack levels as required by interim fix and then apply Interim Fix Interim Fix PI65218 and PI65853
-- OR
  • Apply Fix Pack 13 (8.0.0.13), or later.

For V7.0.0.0 through 7.0.0.41:
  • Upgrade to minimal fix pack levels as required by interim fix and then apply Interim Fix PI65218
-- OR
  • Apply Fix Pack 43 (7.0.0.43), or later.

For V9.0.0.0 using Compute Grid: --OR--
  • Apply Fix Pack 9.0.0.1 or later.

For V8.5.0.0 through 8.5.5.10 using Compute Grid: --OR--
  • Apply Fix Pack 8.5.5.11 or later.

For V8.0 through 8.0.0.12 using Compute Grid
--OR--
  • Apply Compute Grid Fix Pack 8.0.0.6 or later (when available).

Workarounds and Mitigations

none

Get Notified about Future Security Bulletins

Important note

IBM strongly suggests that all System z customers be subscribed to the System z Security Portal to receive the latest critical System z security and integrity service. If you are not subscribed, see the instructions on the System z Security web site. Security and integrity APARs and associated fixes will be posted to this portal. IBM suggests reviewing the CVSS scores and applying all security or integrity fixes as soon as possible to minimize any potential risk.

References

Complete CVSS v3 Guide
On-line Calculator v3

Related information

IBM Secure Engineering Web Portal
IBM Product Security Incident Response Blog

Change History

23 August 2016: original document published
24 August 2016: updated compute grid fixpack
13 September 2016: update fixpack release dates
17 January 2017: added warning message information

*The CVSS Environment Score is customer environment specific and will ultimately impact the Overall CVSS Score. Customers can evaluate the impact of this vulnerability in their environments by accessing the links in the Reference section of this Security Bulletin.

Disclaimer

According to the Forum of Incident Response and Security Teams (FIRST), the Common Vulnerability Scoring System (CVSS) is an "industry open standard designed to convey vulnerability severity and help to determine urgency and priority of response." IBM PROVIDES THE CVSS SCORES "AS IS" WITHOUT WARRANTY OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY.

Cross reference information
Segment Product Component Platform Version Edition
Application Servers WebSphere Extended Deployment Compute Grid
Application Servers WebSphere Application Server Hypervisor Edition

Document information

More support for: WebSphere Application Server

Software version: 7.0, 8.0, 8.5, 8.5.5, 9.0.0.0

Operating system(s): AIX, HP-UX, IBM i, Linux, Solaris, Windows, z/OS

Software edition: Base, Developer, Express, Network Deployment

Reference #: 1987864

Modified date: 13 September 2016