IBM Support

Database connection fails with authentication error SQL1639N

Troubleshooting


Problem

Connection to database when using username and password can fail with error SQL1639N The database server was unable to perform authentication because security-related database manager files on the server do not have the required operating system permissions.

Cause

This is caused by incorrect permissions and ownership of the following security files in ~/sqllib/security directory
db2chpw
db2ckpw

These files should have root as owner and must have permission -r-s--x--x

Resolving The Problem

Change the owner of the files to root

Change the permission of the files to -r-s--x--x

Update the instance using db2iupdt

[{"Product":{"code":"SSEPGG","label":"Db2 for Linux, UNIX and Windows"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Database Objects\/Config - Authorization\/Privilege","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"}],"Version":"9.7;10.1;10.5","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
16 June 2018

UID

swg21987678