Troubleshooting
Problem
The following errors may be seen in the dsmerror.log when attempting a client schedule backup: ANS1909E The scheduled command failed. ANS1512E Scheduled event 'TESTSCHED' failed. Return code = 126.
Cause
The backup script file is missing the execute permission
Diagnosing The Problem
To check the configuration, run a manual backup (that should completes successfully).
Check the schedule on the IBM Spectrum Protect server to determine the name of the backup script that is being run, for example issue the command:
- "q schedule <domain_name> <schedule_name>"
- Policy Domain Name: TESTDOMAIN
Schedule Name: TESTSCHEDULE
Description:
Action: Command
Subaction:
Options:
Objects: /var/scripts/tsmbkp.sh
Run this script manually on the client machine to check that it works successfully
Resolving The Problem
In this case, the backup script did not have execute permission. When running the OS command:
>ls -l /var/scripts/tsmbkp.sh
- -rw-r----- 1 root system 1883 Jul 18 12:27 /var/scripts/tsmbkp.sh
Update the script permission to include execute, for example:
- >chmod +x /var/scripts/tsmbkp.sh
-rwxr-x--- 1 root system 1883 Jul 18 12:27 /var/scripts/tsmbkp.sh
[{"Product":{"code":"SSEQVQ","label":"IBM Spectrum Protect"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Client","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"}],"Version":"Version Independent","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]
Product Synonym
TSM
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Document Information
Modified date:
17 June 2018
UID
swg21987512