IBM Support

Cognos BI and TLS 1.2 support

Troubleshooting


Problem

What version of Cognos BI or Analytics support TLS 1.2?

Symptom

Suggestion: Provide the full text transcript of the error.

Cause

CRITICAL: Provide the reason for the issue if known.

Resolving The Problem

Cognos 11 supports TLS 1.2
Cognos 10.2.2 with FP8 supports TLS 1.2
Cognos 8.4.1, 10.1.x and 10.2.x started supporting TLS 1.2 after the upgrade to OpenSSL 1.0.2e that went in the IBM Cognos Business Intelligence Server 2016 Q1 Security Updater (http://www-01.ibm.com/support/docview.wss?uid=swg21979767)

To verify if a Cognos installation can accept TLS 1.2 connection, you can run one of the following command (change port if required);
curl [https://cognosBI.ibm.com:9300] --tlsv1.2 --verbose -k
or
openssl s_client -connect cognosBI.ibm.com:9300 -tls1_2

Starting with the 2016 Q1 security updaters and 10.2.2 FP5 the setup will no longer update the OPENSSL version in the cmplst.txt. In order to correctly determine which version of OPENSSL is installed, check the openssl-xxxx-app.ver file in the <install root>\vers folder. This design change was made to accommodate the move from OPENSSL version 0.9 to 1.0.

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"10.1;10.1.1;10.2;10.2.1;10.2.2;8.4.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
12 August 2020

UID

swg21986882