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** Troubleshooting ** "An error occured while trying to access server" and "...Client found response content type of 'text/html', but expected 'text/xml'..." when launching Controller

Technote (troubleshooting)


Problem(Abstract)

User launches Controller, and splash screen starts. User receives error message, and cannot continue.

Symptom

An error occurred while trying to access the server.

Details:
Client found response content type of '', but expected 'text/xml
The request failed with an empty response.


Cause

There are several possible causes for similar symptoms:

  • Scenario #1 - Missing IIS components on the Controller application server
    • Specifically, only a few IIS roles/features have been installed onto the application server

Example:

In one real-life customer example, only the following IIS components were installed (on their Windows 2012 R2 server):

This compares with the 'correct' components (installed on a working server):




  • Scenario #2 - The Windows user account that is running the Controller logic on the application server does not have write access to required files/folders (located on the Cognos application server itself).
    • For more details, see separate Technote #1345789
  • Scenario #3 - The I.T. person has forgotten to register ASP.NET 2.0 on the Controller application server.
    • For more details, see separate Technote #1662306
  • Scenario #4 - The administrator had forgotten to modify the "web.config" file (inside "cgi-bin") to include the following configuration:
allowPathInfo="true"
  • Scenario #5 - Incorrect IIS Application Pool configuration on the Controller application server.
  • Scenario #6 - The Application Pool that Controller was using was on an incorrect version of .NETFramework.

Diagnosing the problem

Often the best way to diagnose which problem you are suffering from is to launch the Controller diagnostic website. In other words, launch this URL: servername/ibmcognos/controllerserver/ccrws.asmx

Scenario #1
The following error was seen launching the diagnostic website:

        The website cannot display the page
        <...>
        This error (HTTP 500 Internal Server Error) means that the website you are visiting had a server problem which prevented the webpage from displaying.


In addition, there was only one Application Pool visible:


The above compares with a 'good' Windows 2012 R2 application server, which has the following application pools:

Resolving the problem

Scenario #1

Ensure that the Controller application server has all the required IIS components installed.

  • These can be added inside the 'Roles and Features' section of Windows server.

Scenario #2
See separate Technote #1345789

Scenario #3
See separate Technote #1662306

Scenario #4
See separate Technote #1653338

Scenario #5
See separate Technote #1661800

Scenario #6
See separate Technote #1960504

Related information

1345789 - "An error occured while trying to access serv
1662306 - "An error occurred while tring to access the
1653338 - "An error occurred ... Request format is unre
1661800 - "An error occurred...500.19 - Internal Server
1960504 - Application Pool Settings when both Controlle

Document information

More support for: Cognos Controller
Controller

Software version: 10.2.1

Operating system(s): Windows

Reference #: 1986254

Modified date: 28 June 2016