IBM Support

Security Bulletin: XML External Entities Injection Vulnerability in IBM Traveler (CVE-2016-3039)

Security Bulletin


Summary

IBM Traveler is vulnerable to a denial of service caused by an XML External Entity Injection (XXE) error when processing XML data.

Vulnerability Details

CVEID: CVE-2016-3039
DESCRIPTION: IBM Traveler is vulnerable to a denial of service, caused by an XML External Entity Injection (XXE) error when processing XML data. A remote attacker could exploit this vulnerability to expose highly sensitive information or consume all available memory resources.

Affected Products and Versions

IBM Traveler 8.5.3
IBM Traveler 9.0
IBM Traveler 9.0.1

Remediation/Fixes

Traveler 9.0.1.12 and later versions have been updated to address the vulnerability. See APAR LO89357 for details. It is recommended that all Traveler servers be upgraded to Traveler 9.0.1.12 or later. Refer to the following technote for the latest Traveler maintenance: Index of recommended maintenance for IBM Traveler


For versions no longer supported such as IBM Traveler 8.0.1, 8.5.0, 8.5.1 and 8.5.2, IBM recommends upgrading to a fixed, supported version of the product.

Workarounds and Mitigations

None

Get Notified about Future Security Bulletins

References

Related information

Change History

13 July 2016 - Original version published

*The CVSS Environment Score is customer environment specific and will ultimately impact the Overall CVSS Score. Customers can evaluate the impact of this vulnerability in their environments by accessing the links in the Reference section of this Security Bulletin.

Disclaimer

According to the Forum of Incident Response and Security Teams (FIRST), the Common Vulnerability Scoring System (CVSS) is an "industry open standard designed to convey vulnerability severity and help to determine urgency and priority of response." IBM PROVIDES THE CVSS SCORES "AS IS" WITHOUT WARRANTY OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY.

Document information

More support for: IBM Traveler
Security

Software version: 8.0.1, 8.5, 8.5.1, 8.5.2, 8.5.3, 9.0, 9.0.1

Operating system(s): IBM i, Linux, Windows

Software edition: All Editions

Reference #: 1985858

Modified date: 13 July 2016