IBM Support

Error #2072 'There was an unanticipated problem with the license for this product.' A license check is performed by the system when IBM SPSS Statistics or Modeler is started.

Question & Answer


Question

Error #2072 'There was an unanticipated problem with the license for this product.' When running IBM SPSS Statistics or Modeler.

Cause

When starting IBM SPSS Statistics or Modeler, a license check is performed by the system. That check is failing. There are several possible causes:

· The license is valid, but for a different product or version.
· The license is valid, but for a different machine.
· The license is valid, but does not have the proper settings for your installation.
· The license if for a desktop install, but was used on a License Manager or visa versa.

The specific symptom number will help determine which possible cause will resolve your issue.

  1. Specific Symptom #4 locally licensed
  2. Specific Symptom #4 on a License Manager
  3. Specific Symptom #4 Mac with Thunderbolt Technology
  4. Specific Symptom #4 Statistics 20 broken after Upgrade to Mountain Lion
  5. Specific Symptom #6
  6. Specific Symptom #15
  7. Specific Symptom #25
  8. Specific Symptom #62 on a Redundant License Manager
  9. Specific Symptom #133
  10. Specific Symptom #188
  11. How to contact Support

Answer

Specific Symptom #4 locally licensed

Your license can be generated with the incorrect settings. Determining whether an incorrectly generated license is the issue, use the How to contact Support Support Request information to contact IBM SPSS Technical Support, who review the license and make corrections if necessary. You must apply the license after the corrections are made in order for them to take effect.

Specific Symptom #4 on a License Manager

A license check is performed from the client machine (users computer) to the server hosting the license manager when an IBM SPSS Statistics or Modeler installation is licensed by a license Manager, If the licenses for IBM products are not valid, your license check fails. The most likely cause of the problem is the hardware on the server that is hosting the license manager changed. If you encounter this scenario, contact your company's IT department and ask them to check the code. The IT Team can contact IBM to determine what steps are required to correct the license issue.

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Specific Symptom #4 - Mac with Thunderbolt Technology

To correct the error (2072/4) you need to change the Statistics application's tethering locking code from using a NIC Card tether (10) to using a hard disk drive tether (4), which is less likely to change.

You need to know the path of where IBM SPSS Statistics is installed. Depending on the version of Statistics you installed the paths vary. NOTE: Steps 1 through 6 can vary should the softwares default path was not used. Modify accordingly.

Here are some of versions of Statistics and their default paths.

[Defaults paths]
Statistics 21.0: /Applications/IBM/SPSS/Statistics/21/SPSSStatistics.app/Contents/bin
Statistics 22.0: /Applications/IBM/SPSS/Statistics/22/SPSSStatistics.app/Contents/bin
Statistics 23.0: /Applications/IBM/SPSS/Statistics/23/SPSSStatistics.app/Contents/bin

============================================
1) Open up FINDER
2) Open up the APPLICATIONS folder
3) Open up the IBM folder
4) Open up the SPSS folder
5) Open up the Statistics folder
6) Open up the version of Statistics xx.x (21, 22, 23, xx, depending on the installed version of Statistics)
7) Locate the "SPSSStatistics.app" (application bundle) right click and choose "Show Package Contents".
8) Open up the "Contents" folder
9) Open up the "bin" folder
10) Locate and Control Click echoid.dat and choose Open With, and then choose
TextEdit.app
11) Change the 0x010 to 0x004
12) Save the echoid.dat file
13) Delete the current lservrc file in this directory (if one exists, if not continue)
14) Run the License Authorization Wizard
15) Re-launch Statistics. The software should now launch without error.

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Specific Symptom #4 - Statistics 20 broken after Upgrade to Mountain Lion

The error is due to a lock code change after the Operating System upgrade. NOTE: IBM SPSS Statistics 20.0 is not formally supported on MAC OSX 10.8 (Mountain Lion). We suggest upgrading to version 21.0, which was fully tested and is supported. Any issues that you might encounter using version 20 on Mountain Lion will be addressed in future releases or FixPacks for 21. That said, we don't anticipate any significant problems with using version 20 on Mountain Lion, and are providing this installation information as a courtesy. To resolve the licensing problem on version 20, rerun the license Authorization Wizard (LAW) and enter the Authorization Code to activate the IBM SPSS Statistics product. IBM cannot guarantee the performance of any versions earlier than 20 on Mountain Lion and can suggest that you install those versions only on formally supported operating systems.

Specific Symptom #6

This error indicates license code that is generated by the IBM SPSS license Authorization Wizard failed to use the complete lock code when it was created. To correct the problem, run the IBM SPSS license Authorization Wizard again. You can also use the Support Request information to check or correct your code.

Specific Symptom #15

The Specific Symptom #15 error message is caused by the license Manager administrator, creating a reserved license, which excludes your workstation from using the license manager. Check with the administrator as the configuration can be intentional. The license manager reservation file that is created can be edited to include the affected machines, if necessary. Review the topic "Setting Group Reservations" in the Sentinel RMS license Manager help for more information.

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Specific Symptom #25

There are two common causes for Error 2072 Specific Symptom #25:

(1) If the desktop product exhibiting symptom 25 uses a License Manager for licensing, the likely cause is an incompatibility between the version of the licensing technology of the License Manager and the desktop product (client). For details see TechNote 2015199.

(2) A user's account has three consecutive exclamation points in its name. You can correct the problem by renaming the account. To do so, follow these steps:

1. If you aren't already, please login with Administrator privileges to the machine
2. Right click "My Computer' and select "Manage" from the context menu
3. On the left side, expand System Tools->Local Users and Groups->Users
4. On the right side, locate your account, right-click the account name and choose "Rename"
5. Rename the account and press Enter

Specific Symptom #62 on a Redundant License Manager

The error is caused by incorrect codes, most likely the lock codes for the redundant license Manager host computer does not match the lock code that was encrypted into the license string. Open a Support Request to IBM. To resolve the problem, Support requires that you check the lock codes for the three workstations in the redundancy. Support will then create new codes.

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Specific Symptom #133

Specific Symptom #133 is caused by an internet security program (for example, 'personal firewall', 'anti-spyware') preventing SPSS Statistic from recognizing that it is licensed. To restore SPSS Statistics functions, the internet security program on the computer with this error must allow the SPSS Statistics program files 'spss.com' and 'spss.exe' to run without interference. This process is sometimes referred to as 'allowlisting'. See your internet security programs documentation -- or contact the vendor -- for information on how to perform this configuration task

Specific Symptom #188

Most likely there's a problem with your computer's system date. Check it, correct it if necessary, and then relaunch SPSS Statistics. It might be necessary to rerun the license authorization wizard to regenerate your license with the correct system date and time.

How to contact Support

There are multiple ways to contact support. Your support contact depends on the Support Contract you chose at time of purchase.


· Customers with current support contracts can open a Support Request on Support Portal.

· Everyone can use the Predictive Analytics Community Licensing Forums to do the same.

· Students can use the Predictive Analytics Community Student Forums.

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Document Information

Modified date:
16 June 2018

UID

swg21985805