IBM Support

Lanfree backup does not select scratch tape and fails

Question & Answer


Question

Why did Lanfree backup fail even though scratch volumes were available?

Cause

The storage pool used for the backup is collocated by node. The volume selected for the backup operation was not checked into library.

Answer

The storage pool used for the lanfree backup is collocated by node. This is how volumes are selected and in this order according to our documentation.

1) First we will try to find a volume that already contains files from the same client node.
2) Next we will look for an empty predefined volume
3) Then we will look for an empty scratch volume

The following link explains how the server selects volumes with collocation enabled:

https://www.ibm.com/support/knowledgecenter/SSGSG7_6.2.0/com.ibm.itsm.srv.doc/c_colloc_enabled.html

The backup finds a filling volume 12345L5 ( from collocated pool) and uses it for backup, If you run Query libvolume you will see that 12345L5 is not in the library. Because the volume is not in library, the activity log will show the mount request countdown until mount times out. This will cause resource waiter abort that cancels the session and the backup fails. You may see the following or similar messages in the server activity log when this scenario occurs:

ANR8308I LTO volume 12345L5 is required for use in library LTOLIB1 ;
CHECKIN LIBVOLUME required within 60 minutes.

Then you may see the request count down until the mount times out:

ANR8351E 044: Mount request for volume 12345L5 has timed out.
ANR8313E Volume 12345L5 is not present in library LTOLIB1.
ANR9790W Request to mount volume T0T618L5 for library client YOUR_STA failed. ANR0409I (ANE4985I Session: NNNNN , Origin:YOUR_STA Session ended for
server YOURSERVER
ANR1402W (ANE4985I Session: NNNNN, Origin:YOUR_STA) Mount request denied for volume 12345L5 - volume unavailable.

Finally, for the same session, we see resource timeout limit reached and the session fails as well. When this occurs the backup also fails:

ANR0538I A resource waiter has been aborted.
ANR0490I Canceling session for node YOUR_NODE

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Document Information

Modified date:
17 June 2018

UID

swg21985576