Troubleshooting
Problem
Certain post-install steps must be performed after appending a product to an information Server installation to which the JR55026 patch was previously applied. These steps must also be performed after a product is selectively uninstalled from such an Information Server.
Symptom
The post-install steps must be performed if one of the following text strings is found in the ISHOME/Version.xml file:
installerId="bundle_security_JR55026_IIS_all_11312" (11.3.1.2 Information Servers)
installerId="bundle_security_JR55026_IIS_all_912" (9.1.2. Information Servers)
installerId="bundle_security_JR55026_IIS_all_8702" (8.7.0.2 Information Servers)
Here ISHOME refers to the top-level directory of the Information Server installation. On UNIX and Linux platforms this defaults to /opt/IBM/InformationServer. On Windows it defaults to C:\IBM\InformationServer.
Cause
The post-install steps are required to assure proper operation of the update installer after a product is appended to or removed from an affected system.
Environment
This issue applies to any InfoSphere Information Server 8.7.0.2, 9.1.2.0, or 11.3.1.2 system to which the JR55026 patch has been applied. It applies equally to all supported platforms.
Diagnosing The Problem
Search the ISHOME/Version.xml file for the appropriate installerId string as shown above.
Resolving The Problem
The problem can be resolved as follows:
1. Edit the ISHOME/Version.xml file with a text editor.
2. Search for the following PersistedVariable definition:
- <PersistedVariable encrypted="false" name="is.authfile.arguments.supported" persistent="true" readonly="false" value="true"/>
3. If the definition is not found, then insert it after the line:
<PersistedVariables>
4. Save Version.xml.
These steps need to be repeated each time a product or PACK is appended to the installation, and each time a product or PACK is removed from the installation.
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Document Information
Modified date:
16 June 2018
UID
swg21985471