IBM Support

Date fields are displaying one day off in the BIRT report

Troubleshooting


Problem

When displaying date fields from a query, the BIRT report is displaying one day before, e.g., 06/02/2015 shows 06/01/2015

Cause

Legacy Date Only fields in the application are store in the back-end database as Date and Time format, where the time is set by default to 00:00:00 as it is not used in the front end.

The BIRT reports interprets this as the day before (midnight), while TRIRIGA displays as the current day (zero hour).

Environment

BIRT reports running on queries that display Date Only fields.

Diagnosing The Problem

Run a query directly to the database and check if the date only field contains also the time stored with it. Observe if the time is 00:00:00.

Resolving The Problem

Update the records by adding one hour to the back-end database fields, i.e., modify fields from a format of 99/99/9999 00:00:00 to 99/99/9999 01:00:00.
The BIRT reports would now consider the day as the same as the front end TRIRIGA application.

[{"Product":{"code":"SSHEB3","label":"IBM TRIRIGA Application Platform"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"IBM TRIRIGA Application Platform Runtime Engine","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"Version Independent","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 June 2018

UID

swg21984155