IBM Support

Is Office 365 supported for Controller?

Question/Answer


Question

Does Cognos Controller support Microsoft Office 365?

Cause

The supported environments for all versions of Controller are listed on the IBM website, for example:

  • Controller 10.2.1 supported environments are available from separate Technote #7045010
  • Controller 10.3.0 supported environments are available from separate Technote #7048987
  • Controller 10.3.1 supported environments are available from separate Technote #7050385.
  • Controller 10.4.0 supported environments are available from the Cognos Controller 10.4.0 Product Compatibility Report page.


However, MS Office 365 is not a 'traditional' single product. Instead, it is a subscription plan which allows users to download/run the very latest version of Office. In other words, customers who own Office 365 licenses will probably be upgrading their Excel versions (over time) as new MS Excel versions are released.

=> This makes it impossible to give a simple 'yes/no' answer to the question to whether IBM Cognos Controller supports MS Office 365.

Answer

Microsoft Office 365 is supported so long as all of the following conditions are met (varies depending on Controller version):

Controller 10.2.1 RTM (10.2.5100.95) to FP3 (10.2.5130.56) inclusive:

  • Only Office 365 version 2013  supported   (not Office 2016)  
  • Only 32-bit versions of MS Office are supported
  • Office 365 must have been installed via the traditional installation method
  • Using desktop-installed (downloaded) Office 365 (not the cloud version of Office 365).

Controller 10.2.1 FP4 (10.2.5140.12) to FP4 IF15 (original 10.2.5140.45) inclusive:

  • Office 365 version 2016 is now supported (plus version 2013)
  • Only 32-bit versions of MS Office are supported
  • Office 365 must have been installed via the traditional installation method
  • Using desktop-installed (downloaded) Office 365 (not the cloud version of Office 365).

Controller 10.2.1 FP4 IF16 (new 10.2.5140.45) and later 10.2.1.x versions inclusive:

  • Office 365 versions 2013 and 2016 are supported
  • Only 32-bit versions of MS Office are supported
  • Either
    • Office 365 has been installed via the traditional installation method
    • or you have installed Office 2016 (version 1708 build 8431.2094 or higher) via click to run
  • Using desktop-installed (downloaded) Office 365 (not the cloud version of Office 365).

Controller 10.3.0

  • Office 365 versions 2013 and 2016 are supported
  • Either
    • Office 365 has been installed via the traditional installation method
    • or you have installed Office 2016 (version 1708 build 8431.2094 or higher) via click to run (and are using Controller 10.3.0 FP1 or later)
  • Both 32-bit and 64-bit versions of MS Office are supported
  • Using desktop-installed (downloaded) Office 365 (not the cloud version of Office 365).

Controller 10.3.1

  • Office 365 versions 2013 and 2016 are supported
  • Either
    • Office 365 has been installed via the traditional installation method
    • or you have installed Office 2016 (version 1708 build 8431.2094 or higher) via click to run
  • Both 32-bit and 64-bit versions of MS Office are supported
  • Using desktop-installed (downloaded) Office 365 (not the cloud version of Office 365).

Controller 10.4.0

  • Office 365 versions 2013 and 2016 are supported
  • Either
    • Office 365 has been installed via the traditional installation method
    • or you have installed Office 2016 (version 1708 build 8431.2094 or higher) via click to run
  • Both 64-bit versions of MS Office are 'actively' supported (32-bit are also supported as 'compatible')
  • Using desktop-installed (downloaded) Office 365 (not the cloud version of Office 365).

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For the avoidance of doubt, Office 365 is not supported when running directly in the Cloud (instead of running on the desktop/laptop directly).

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Q1 - What are the different methods to install Microsoft Office 365?
Microsoft Office 365 can be installed in two different ways:


  • (1) Traditional method
    • This is sometimes called the 'MSI' or 'Windows Installer' method
      • It is also sometimes known as the 'Volume License' method
    • The application is installed (and runs) natively/directly on the users client device

    (2) Click-to-run
    • The user "streams" the portion of Office that they need (downloading extra portions as and when they need it). The software is running in an isolated 'Sandbox' environment ('virtual bubble') on the computer.


Q2 - What is 'Click to Run' ?
Click-to-Run is a streaming and virtualization technology that is designed to significantly reduce the time that is required to download and use Office client products. Streaming allows users to begin to use a Click-to-Run product before the complete product is downloaded.

Click-to-Run for Office 365 products are based on core virtualization and streaming Microsoft Application Virtualization (App-V) technologies. Click-to-Run resources run in an isolated virtual environment on the local operating system.

Q3 - How can I check if my installation is 'traditional' or 'click to run'?

  • Method #1 (recommended)

1. Launch Excel (or Outlook or Word).
2. Click "File - Account" (or Office Account).

- If you see an "Update Options" item, you have a Click-to-Run installation
- If you don't see the "Update Options" item, you have an MSI-based install.

  • Method #2 (alternative)

See where EXCEL.EXE is installed/run from:

  • (1) Traditional (MSI):
    By default, EXCEL.EXE is located in the following locations:
    • Office 2013 (32-bit): C:\Program Files (x86)\Microsoft Office\Office15\
    • Office 2016 (32-bit): C:\Program Files (x86)\Microsoft Office\root\Office16\

    (2) Click to Run:
    By default, EXCEL.EXE is located in the following locations:
    • Office 2013 (32-bit): C:\Program Files (x86)\Microsoft Office 15\ClientX64\Root\Office15\
    • Office 2016 (32-bit): C:\Program Files (x86)\Microsoft Office 16\ClientX64\Root\Office16\


Q4 - What should I do if I have already installed MS Office 365 as 'click to run', and it is unsupported in my version of Controller ?
Either:
(a) Remove the Click-To-Run installed Office. Then install MS Office via the traditional (MSI) method instead
or (b) Upgrade to a later version of Controller (for example 10.3.1) which supports click to run (see above for caveats).

Related information

Enhancement Request - Office 365
7045010 - Controller 10.2.1 Supported Software Environm
Third Party (non-IBM) - MSI vs Click To Run Office inst
7048987 - Controller 10.3 Supported Software Environmen
7050385 - Controller 10.3.1 Supported Software Environm
Cognos Controller 10.4.0 Product Compatibility Report

Document information

More support for: Cognos Controller

Component: --

Software version: 10.2.1, 10.3, 10.3.1

Operating system(s): Windows

Software edition: All Editions

Reference #: 1984103

Modified date: 03 May 2019