IBM Support

Images do not replicate in records when having separate application servers.

Troubleshooting


Problem

Sometimes customer can find the scenario where the images in created in one record, such as the employee record, can be visualized when the user logs into one of the app servers but not on other ones. All other information on the records replicate just fine between servers.

Symptom

No images in one or more application servers.

Cause

This is caused because the image is stored in the userfiles/images or userfiles/Company-1 directories on the application server.

Environment

Any TRIRIGA environment up to 3.4.2.x

Diagnosing The Problem

You need to have an environment with 2 or more application servers.

  • Log into the first one.
  • Create a employee record with an image uploaded to this record.
  • Save the record.
  • Log out and Log into another URL (another app server).
  • Search for the employee record you created.
  • Check and see all information is correct, the image is not displayed.

Resolving The Problem

The workaround is to replicate the file system between the servers.
The best thing is to upgrade to 3.5.0 or later. In Platform 3.5.0 the images were moved to the database and there is no need to replicate the file system.

This is stated in the 10.5.0 Release Notes (link below).

[{"Product":{"code":"SSHEB3","label":"IBM TRIRIGA Application Platform"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"IBM TRIRIGA Application Platform","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"3.3;3.4","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 June 2018

UID

swg21982774