IBM Support

Server installation on Linux fails with requirement check on libstdc++so.5

Technote (troubleshooting)


Problem(Abstract)

When installing Tivoli Storage Manager Server on Linux 64 bit, a Requirement Check is received
on libstdc++so.5 (32-bit and 64-bit)

Symptom

TSM Environment Check
---------------------

The installation wizard cannot run on your configuration. It will now
stop.
For more details about installation error logs, enter the phrase
"installation
log files" in the Search field at this site:
http://publib.boulder.ibm.com/infocenter/tsminfo/v6r3.
Requirement check: Failed
- Deployment Engine installation minimum requirements: libstdc++so.5
(32-bit and 64-bit)


Requirement check: Failed
- Deployment Engine installation minimum requirements: libstdc++so.5
(32-bit and 64-bit)


Cause

Both libstdc++.so 32 and 64 bit packages are required.


Diagnosing the problem

Run "rpm -qa | grep libstdc" to verify if required packages are installed.

Resolving the problem

This is the link which contains the server requirements for 6.3 and 7.1

Server Requirements which contains the necessary libstdc packages:
http://www.ibm.com/support/docview.wss?uid=swg21204361

7.1
GNU C libraries, Version 2.3.3-98.38 or later that is installed on the Spectrum Protect system.
For SUSE Linux Enterprise Servers:
libaio
libstdc++.so.5 at version 3.3 or later (32 and 64 bit packages are required)
libstdc++.so.6 at version 4.3 or later (32 and 64 bit packages are required)

For Red Hat Enterprise Linux Servers:
libaio
libstdc++.so.6 (32 and 64 bit packages are required)
numactl.x86_64
=================================================================
6.3
GNU C libraries, Version 2.3.3-98.38 or later that is installed on the Tivoli
Storage Manager system.
For Red Hat Enterprise Linux and SUSE Linux Enterprise Servers:
libaio.so.1 (32 and 64 bit)
libstdc++so.5 (32 and 64 bit)
libstdc++so.6 (32 and 64 bit)

---------------------------

Install missing libstdc++so.# (32 and 64 bit) packages and retry installation.

Product Alias/Synonym

TSM

Document information

More support for: Tivoli Storage Manager
Server

Software version: 6.3, 7.1

Operating system(s): Linux

Software edition: All Editions

Reference #: 1982473

Modified date: 31 March 2017


Translate this page: