IBM Support

How to run WebSphere Application Server (WAS) Liberty profile as a Windows service.

Troubleshooting


Problem

After installing TRIRIGA in a WAS Liberty profile, the user logged into can not log out or the service will be stopped.

Cause

There is a limitation to WAS Liberty profile that it can not run as a Windows service.

Environment

Windows Server with TRIRIGA 3.4.2 or above and WAS installed as a Liberty Profile.

Resolving The Problem

There is an RFE to implement this and I encourage you to vote for it:
https://www.ibm.com/developerworks/rfe/execute?use_case=viewRfe&CR_ID=29865
You can also check if that has been implemented already in that page.

There is a workaround to use a third party software to have WAS Liberty as a service in Windows.

**DISCLAIMER: This is up to you to implement and it is not supported, you need to make sure to implement based on your system technology and install paths. This instructions are for advanced users.

1. Download the binaries for Windows from:http://www.apache.org/dist/commons/daemon/binaries/windows/

2. Unzip the downloaded file. The correct file depends on your architecture. Save it in your bin folder (the same where run.bat is located, for instance: C:\IBM\Tririga\wlp\bin)

3. Run the following script to create a Manual service. You need to change the values in the variables, and you might need to change other values too (e.g. --Startup if you want this service to be automatic):

Example:
------------------------------------------------------------------------------------------------------------------
@echo off
set DAEMON_EXEC="C:\commons-daemon-1.0.15-bin-windows\amd64\prunsrv.exe"
set SERVER_START_COMMAND="C:\IBM\Tririga\wlp\bin\run.bat"
set SERVER_START_COMMAND_PATH="C:\IBM\Tririga\wlp\bin"
set SERVER_STOP_COMMAND="C:\IBM\Tririga\wlp\bin\shutdown.bat"
set SERVER_STOP_COMMAND_PATH="C:\IBM\Tririga\wlp\bin"
set LOG_PATH="C:\IBM\Tririga\log"
set SERVICE_NAME=TRI342_LIBERTY
set SERVICE_DISPLAY_NAME="TRIRIGA 3.4.2 Liberty Profile"
set SERVICE_DESCRIPTION="TRIRIGA 3.4.2 running in Liberty Profile"
set INSTALL_SERVICE_COMMAND=%DAEMON_EXEC% //IS//%SERVICE_NAME% --Startup=manual --DisplayName=%SERVICE_DISPLAY_NAME% --Description=%SERVICE_DESCRIPTION% ++DependsOn=Tcpip --LogPath=%LOG_PATH% --StdOutput=auto --StdError=auto --StartMode=exe --StartPath=%SERVER_START_COMMAND_PATH% --StartImage=%SERVER_START_COMMAND% --StopMode=exe --StopPath=%SERVER_STOP_COMMAND_PATH% --StopImage=%SERVER_STOP_COMMAND%
%INSTALL_SERVICE_COMMAND%
------------------------------------------------------------------------------------------------------------------

4. Open the windows services application.

5. Locate the IBM Liberty Server service, right click, start.

Note: If you run into any issues check the logs in the LogPath directory location for any errors - the errors as listed in the event viewer logs from Windows do not give meaningful errors.

[{"Product":{"code":"SSHEB3","label":"IBM TRIRIGA Application Platform"},"Business Unit":{"code":"BU055","label":"Cognitive Applications"},"Component":"IBM TRIRIGA Application Platform","Platform":[{"code":"PF033","label":"Windows"}],"Version":"3.4.2;3.5","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}},{"Product":{"code":"SSEQTP","label":"WebSphere Application Server"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSD28V","label":"WebSphere Application Server Liberty Core"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21982328