IBM Support

Get "The name of CustomExtension plug-in errors" with CIWEB2039 code when accessing Case Client page after a successful run of "Deploy and Register Extension Package" task via Case Manager configuration tool commandline.

Troubleshooting


Problem

After the successful run of "Deploy and Register Extension Package" task via Case Manager configuration tool commandline, every time a user tried to access Case Client URL, the user received "The name of CustomExtension plug-in errors" with CIWEB2039 error code.

Symptom

Here is the excerpt from WAS SystemOut.log :

[3/16/16 14:17:50:516 PDT] 00000172 SystemOut O CIWEB Debug: [ @ 10.151.194.55] [REQUEST 14326] com.ibm.ecm.servlets.PluginServlet.process() Plugin: nameofCustomExtensions, action: getResource, resource: customtextbox/Initializer.js
[3/16/16 14:17:50:516 PDT] 00000172 SystemOut O CIWEB Entry: [ @ 10.151.194.55] [REQUEST 14326] com.ibm.ecm.util.PluginUtil.executeAction()
[3/16/16 14:17:50:517 PDT] 00000172 SystemOut O CIWEB Entry: [ @ 10.151.194.55] [REQUEST 14326] com.ibm.ecm.util.PluginUtil.executeAction()
[3/16/16 14:17:50:517 PDT] 00000172 SystemOut O CIWEB Exit : [ @ 10.151.194.55] [REQUEST 14326] com.ibm.ecm.servlets.PluginServlet.process()
[3/16/16 14:17:50:518 PDT] 00000172 SystemOut O CIWEB Debug: [ @ 10.151.194.55] [REQUEST 14326] com.ibm.ecm.servlets.PluginServlet.process() -------- END REQUEST 14326 ---------
[3/16/16 14:17:50:629 PDT] 00000172 SystemOut O CIWEB Debug: [ @ 10.151.194.55] [REQUEST 14326] com.ibm.ecm.filters.GZipFilter.doFilter() headerName: null
[3/16/16 14:17:50:629 PDT] 00000172 SystemOut O CIWEB Debug: [ @ 10.151.194.55] [REQUEST 14326] com.ibm.ecm.filters.GZipFilter.doFilter() headerValue: null
[3/16/16 14:17:50:629 PDT] 00000172 SystemOut O CIWEB Debug: [ @ 10.151.194.55] [REQUEST 14326] com.ibm.ecm.filters.GZipFilter.doFilter() jgz URI is /navigator/icm/widget/properties/registry/RegistryManager.js
[3/16/16 14:17:50:991 PDT] 00000172 filter E com.ibm.ws.webcontainer.filter.FilterInstanceWrapper doFilter SRVE8109W: Uncaught exception thrown by filter GZipFilter: java.io.FileNotFoundException: SRVE0190E: File not found: /icm/widget/properties/registry/RegistryManager.js
at com.ibm.ws.webcontainer.extension.DefaultExtensionProcessor._processEDR(DefaultExtensionProcessor.java:949)
at com.ibm.ws.webcontainer.extension.DefaultExtensionProcessor.processEDR(DefaultExtensionProcessor.java:930)

...

Cause

This has been identified as a product defect under APAR PJ44102.

After "Deploy and Register Extension Package" task to install a custom plugin package for IBM Case Manager, the code related to the plugin package will not load as it is not able to find dependent IBM Case Manager (ICM) javascript classes.

In checking the plugin order in IBM Content Navigator, where the extension plugin is installed, the new extension plugin is installed on top of the IBM Case Manager API plugin. The ICM API plugin sets up the environment for ICM classes to load correctly in the ICN framework. If a custom plugin references ICM classes, the plugin needs to be ordered after the ICM API plugin.

Environment

Linux, IBM Case Manager 5.2.1.3

Resolving The Problem

The fix will be included in a future IBM Case Manager 5.2.1 fix pack release. It is likely to be included in ICM 5.2.1.5. In the meantime, as a workaround, log on to IBM Content Navigator administration desktop, double-click on the Plug-ins on the left pane and on the right pane, select the custom plugin that references ICM classes and move it after the ICM API plugin.

[{"Product":{"code":"SSCTJ4","label":"IBM Case Manager"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Case Manager Config Tool","Platform":[{"code":"PF016","label":"Linux"}],"Version":"5.2.1.3","Edition":"All Editions","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21982139