IBM Support

JazzSM/DASH installation failure: CTGWA0134E Fail to import widgets.zip

Troubleshooting


Problem

A fresh install of the DASH Service of Jazz for Service Management into WAS 8.5.5.9 fails executing steps from the tipWrapperInstall.xml. The error reads: "CTGWA0134E Fail to import widgets.zip"

Cause

Websphere 8.5.5.9 is missing jar files that exist in prior Websphere releases and are needed by DASH scripts that are executed by the JazzSM installer.

Diagnosing The Problem

Review the ant log referenced in the installation log just after the the "CTGWA0134E" error. Look for the result of the "restcli" execution. The error for that execution will look like:

###

[echo] Wrapper invoking command: /opt/IBM/JazzSM/ui/bin/restcli.sh at 04/12/2016 10:54:46
[echo]
[echo] ATKRST201E The command failed to complete. The HTTP Response code is as follows: 500.
###

Resolving The Problem

There are a couple options listed below to address the issue. However, before attempting either option, manual clean up of the failed installation is required. Do the following before trying either of the two options:


1. Remove the "JazzSM" installation directory that was created by the first installation attempt.  By default the directory is created under:

/opt/IBM/

 
2. Remove the Websphere profile created by the first installation attempt:
1. Navigate to the bin directory under the Websphere installation directory (default:  /opt/IBM/WebSphere/AppServer/bin)
2. Execute the following command to list the profiles that exist for the WAS instance:

./manageprofiles.sh -listProfiles
 
3. Delete the profile for JazzSM (default:  "JazzSMProfile") using the following command:

./manageprofiles.sh -delete -profileName JazzSMProfile

 
Once you done the above cleanup steps, carry on with one of the following two options:

Option 1:
Uninstall WAS 8.5.5.9 and retry the JazzSM/DASH install using a lower WAS version (e.g. 8.5.0.1 - 8.5.5.8).

Option 2:

  1. When you are installing DASH using IM, there would be a feature tree panel, where you can see following 2 features:

    Installation
    Configuration

    Unselect Configuration feature and then install DASH binary files.

  2. Once installation is done modify file "/opt/IBM/JazzSM/install/tip/tipWrapperInstall.xml" by commenting the ant target which makes call to "importWidget".  Change the line:

        <antcall target="importWidgets" />
    to:
        <!-- FLH Feb 9th 2016 - antcall target="importWidgets" -->

    Then start IM again and click on Modify and select Configuration feature for DASH.
  3. Once the configuration step has completed, install DASH 3.1.2.1 cumulative patch 5. That will add the jar files that are missing from WAS 8.5.5.9. Acquire DASH 3.1.2.1 cumulative patch 5 from IBM Fix Central.
  4. Execute the restcli command that was originally causing the JazzSM/DASH install to fail. Execute the command as follows:

    /opt/IBM/tivoli/JazzSM/ui/bin/restcli.sh import -username smadmin -password <smadmin password> -source /opt/IBM/tivoli/JazzSM/ui/installableApps/widgets.zip

    replace "<smadmin password>" with the actual smadmin password.
    Change the JazzSM install paths if needed to match the actual install path used for the JazzSM installation.
The DASH install should be installed and fully functional.

[{"Product":{"code":"SSRLR8","label":"Tivoli Components"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Jazz for Service Management","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"Version Independent","Edition":"","Line of Business":{"code":"","label":""}}]

Document Information

Modified date:
17 June 2018

UID

swg21981746